View Issue Details

IDProjectCategoryView StatusLast Update
0018001phpList 3 applicationHTML Email Supportpublic11-05-17 20:19
ReporterEhaver282 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version3.2.4 
Target Versionnext patchFixed in Version 
Summary0018001: RFC Compliance Issues.
DescriptionI have two systems set up using PHPList. One system is using an old version: 2.10.15 and another is using the current version.

I am attempting to send an email to a GMAIL account. When sent from the old system, the message works fine, so I copied the message from the old to the new system. When I try to test it on the new system I get a bounce back stating the message isn't RFC 5322 complaint.

I have checked the config files for both and everything is matching. Is there something different between the two versions that would cause the same email to not work on both?

Thank you.
Steps To ReproduceCreate a Campaign with the following content and attempt to send message to a gmail account, you can use havermale.ernie@gmail.com if one is unavailable.:

<table align="center" bgcolor="#ffffff" border="0" cellpadding="0" cellspacing="0" width="590">
    <tbody>
        <tr>
            <td align="center" height="40" style="font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 16pt; font-weight: bold;" valign="middle">»  <a href="mailto:gb@jetsearch.com?subject=Inquiry%20Received%20from%20Plane%20Mover%20Blitz%3A%20Challenger%20605%20%235714"> <span style="font-size: 11pt;">Click Here to Inquire</span></a>  «</td>
        </tr>
    </tbody>
</table>

<table align="center" bgcolor="#000000" border="0" cellpadding="0" cellspacing="0" style="font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif;" width="590">
    <tbody>
        <tr>
            <td height="110" style="text-align: center; color: rgb(159, 0, 0); font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 18pt; font-weight: bold;"><span style="color: rgb(46, 153, 170); font-size: 26pt; font-style: italic;">Priced For Immediate Sale!</span>

            Available for Visual in the US

            Starting February 6, 2015</td>
        </tr>
        <tr>
            <td><a href="http://www.planemover.com/Aircraft/ForSale/2479/Challenger_605/Challenger_605_-_sn%3A_5714/"><img alt="More Details..." border="0" height="276" src="http://www.planemover.com/emails/images/CTI-GLOBALJETSALES/CL605_5714/EXT.png" width="590" /></a></td>
        </tr>
        <tr>
            <td height="40" style="text-align: center; color: rgb(255, 255, 255); line-height: 24pt; font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 20pt; font-weight: bold;">Challenger 605 - s/n: 5714</td>
        </tr>
        <tr>
            <td>
            <hr color="#ca9865" size="1" width="98%" /></td>
        </tr>
        <tr>
            <td>
            <table align="center" border="0" cellpadding="0" cellspacing="0" width="530">
                <tbody>
                    <tr>
                        <td height="50" style="text-align: center; color: rgb(46, 153, 170); line-height: 20pt; font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 16pt; font-style: italic;" width="55%">96 month and Landing Gear Inspections

                        c/w 10/2015 @ Duncan Battle Creek</td>
                    </tr>
                </tbody>
            </table>
            </td>
        </tr>
        <tr>
            <td>
            <table align="center" border="0" cellpadding="0" cellspacing="0" width="570">
                <tbody>
                    <tr>
                        <td height="50" style="text-align: center; color: rgb(255, 255, 255); line-height: 19pt; font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 14pt;" width="60%">3043 TT <span style="color: rgb(202, 152, 101);">•</span> 12 Passenger <span style="color: rgb(202, 152, 101);">•</span> GE OnPoint <span style="color: rgb(202, 152, 101);">•</span> Smart Parts

                        <span style="color: rgb(202, 152, 101);">All Written Offers Presented!</span></td>
                    </tr>
                </tbody>
            </table>
            </td>
        </tr>
        <tr>
            <td>
            <hr color="#ca9865" size="1" width="98%" /><a href="http://www.planemover.com/Aircraft/ForSale/2479/Challenger_605/Challenger_605_-_sn%3A_5714/"><img alt="More Details..." border="0" height="142" src="http://www.planemover.com/emails/images/CTI-GLOBALJETSALES/CL605_5714/INT.png" width="590" /></a></td>
        </tr>
        <tr>
            <td>
            <table align="center" border="0" cellpadding="0" cellspacing="0" width="100%">
                <tbody>
                    <tr>
                        <td>
                        <hr color="#ca9865" size="1" width="570" /></td>
                    </tr>
                    <tr>
                        <td align="center" height="40" style="color: rgb(255, 255, 255); font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 14pt; font-style: italic;" valign="middle">For More Information, Please Contact:</td>
                    </tr>
                    <tr>
                        <td align="center" height="150"><a href="http://www.jetsearch.com/index.php/home3"><img alt="Go to Company Website..." border="0" height="121" src="http://www.planemover.com/emails/images/CTI-GLOBALJETSALES/NEWLOGO_45YEARS.jpg" width="425" /></a></td>
                    </tr>
                    <tr>
                        <td align="center" style="text-align: center; color: rgb(255, 255, 255); line-height: 18pt; font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 13pt;">Garrett Burke  <span style="color: rgb(202, 152, 101);">•</span>  +1 727.231.1744  <span style="color: rgb(202, 152, 101);">•</span>  <a href="mailto:gb@jetsearch.com?subject=Inquiry%20Received%20from%20Plane%20Mover%20Blitz%3A%20Challenger%20605%20%235714"><font color="#ffffff">gb@JetSearch.com</font></a></td>
                    </tr>
                    <tr>
                        <td align="center" height="50" valign="middle"><a href="http://www.planemover.com/Aircraft/Companies/Global_Jet_Sales/ForSale/?ordering=Property.name"><span style="color: rgb(202, 152, 101); font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 10pt; font-style: italic; font-weight: bold;">View our listings on PlaneMover.com</span></a></td>
                    </tr>
                    <tr>
                        <td align="center">
                        <hr color="#333333" size="1" width="570" /></td>
                    </tr>
                </tbody>
            </table>
            </td>
        </tr>
        <tr>
            <td>
            <table align="center" border="0" cellpadding="0" cellspacing="0" width="100%">
                <tbody>
                    <tr>
                        <td align="center" height="60" style="text-align: center; color: rgb(46, 153, 170); line-height: 16pt; font-family: Verdana, Tahoma, Arial, Trebuchet MS, sans-serif; font-size: 10pt; font-weight: bold;" valign="middle">Asia Partner:

                        <font color="#2e99aa">OrientSKYs</font> | Trevor Merszei | <a href="mailto:BlitzReply@Jetsearch.com?subject=Inquiry%20Received%20from%20Plane%20Mover%20Blitz%3A%20Challenger%20605%20%235714"> <span style="color: rgb(46, 153, 170); font-size: 9pt;">trevor@OrientSKYs.com</span></a></td>
                    </tr>
                </tbody>
            </table>
            </td>
        </tr>
    </tbody>
</table>
<!-- PM Footer Begins updated Nov 2015 -->

<table align="center" border="0" cellpadding="0" cellspacing="0" width="590">
    <tbody>
        <tr>
            <td bgcolor="#ffffff">
            <table align="center" border="0" cellpadding="0" cellspacing="0" width="100%">
                <tbody>
                    <tr>
                        <td colspan="3" style="text-align: center; color: rgb(49, 99, 181); font-family: Verdana,Arial,Helvetica,sans-serif; font-size: 10pt; font-style: italic; font-weight: bold;"> 
                        <hr color="#000000" size="1" width="100%" />Sent Via Plane Mover Blitz...</td>
                    </tr>
                    <tr>
                        <td align="right"><a href="http://www.planemover.com/Seller_Services/Campaigns/Buy_A_Blitz/"><img alt="" border="0" height="80" src="http://www.planemover.com/emails/images/PLANEMOVER%20ADS/buyablitz.jpg" width="69" /></a></td>
                        <td style="text-align: center; color: rgb(0, 0, 0); font-family: Verdana,Arial,Helvetica,sans-serif; font-size: 7.5pt; font-weight: bold;"><span style="font-size: 8pt; font-style: italic; font-weight: bold;">YOUR INTERACTIVE LINK TO WORLDWIDE SALES<span style="color: rgb(221, 41, 5);"> SINCE 2006!</span></span>

                        Have Your http://www.planemover.com/Seller_Services/Campaigns/Buy_A_Blitz/ Sent Across the Globe

                        to Thousands of Owners, Prospects, Dealers & Brokers!

                        Call Toll Free at (866) 659-5400 or email  sales@PlaneMover.com?subject=Buy-A-Blitz%20Inquiry%3A</td>
                        <td align="left"><a href="http://www.planemover.com/" target="_blank"><img align="middle" alt="Visit PlaneMover.com" border="0" height="81" src="http://www.planemover.com/emails/images/PLANEMOVER%20ADS/PM_Footer2014.jpg" title="Visit PlaneMover.com" width="80" /></a></td>
                    </tr>
                </tbody>
            </table>
            </td>
        </tr>
    </tbody>
</table>
TagsNo tags attached.

Activities

michiel

02-02-16 20:40

manager   ~0057487


That sounds very odd. I doubt the RFC compliance is on the content of the message. It must be on headers or something. Or maybe on stuff like newline characters.

Can you post the full headers or both the mail you sent and the bounce?

IIRC, a possible difference may be the line-endings (crlf vs cr vs lf) but I think I made it more compliant and not less.