View Issue Details

IDProjectCategoryView StatusLast Update
0017982phplist applicationAll Otherpublic17-03-16 15:27
Reportergingerling 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Versionnext patchFixed in Version3.2.5 
Summary0017982: email@domain.191.IT addresses seen as invalid
Descriptionclient said

"I have a problem with certain email addresses. In Italy we have a big provider (Telecom Italia) who uses *.191.it as domain for business mail, mani companies and professionals uses 191.it, such as which is perfectly valid, but when I import such emails I get the error:

Rejected email addresses:
name@domain.191.it (actual error is different)

and I always have to reload it skipping the "check for valid email" function."

Wonder if we can add these domains to our list of valid

TagsNo tags attached.

Activities

michiel

12-01-16 22:12

manager   ~0057450


yes, I can replicate this. It is not that we do not allow that domain. It looks like our regex doesn't handle and all-digit second level domain.

michiel

08-03-16 15:54

manager   ~0057556

I've put in a temp hack
https://github.com/phpList/phplist3/commit/764907979b91e7b9fd00f222385b1a331e211f44

duncanc

09-03-16 08:07

developer   ~0057558

I think it is this regex
      $domainPart = "([a-zA-Z0-9](-?[a-zA-Z0-9])*(\.[a-zA-Z](-?[a-zA-Z0-9])*)*\.$topLevelDomain|$domainLiteral)";

each level of the domain after the first has to start with a letter.

michiel

09-03-16 13:19

manager   ~0057559

yes, nice one.

https://github.com/phpList/phplist3/commit/3a5e559bb2dfe764616848597ad7a8ba55df2e4f

gingerling

17-03-16 14:21

manager   ~0057570

Hi

can you let me know when this is pushed to live so I can update client

samtuke

17-03-16 15:27

administrator   ~0057571

As I understand from Michiel, this is already live.