View Issue Details

IDProjectCategoryView StatusLast Update
0017957phplist applicationSubscriber Importpublic02-12-15 19:52
Reporterpnotechnik 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.3 
Target Versionnext patchFixed in Version3.2.4 
Summary0017957: Matching by foreign key does not work
DescriptionIn the current version of phplist (3.2.3) the functionality for matching by foreign key does not work. See "Steps To Reproduce" for further details.
Steps To Reproduce* Create a csv file with following content
Email,Foreign Key
test1@test.tt,1111111

* Import the file with csv import feature and "," as delimiter

* Create a new csv file with following content
Email,Foreign Key
test1-UPDATED@test.tt,1111111

* Import the file with csv import feature and "," as delimiter

* The expected behaviour: Because of matching by foreign key, the email of the subscribe with the foreign key "1111111" and email "test1@test.tt" will be updated to "test1-UPDATED@test.tt"

* The actual behaviour: No subscribe will be imported, the email of the subscriber with foreign key "1111111" will NOT be updated so it has the same value ("test1@test.tt") as before
TagsNo tags attached.

Activities

michiel

01-12-15 23:43

manager   ~0057370

hmm, yes, I can replicate that. Will look at it tomorrow.

michiel

02-12-15 19:52

manager   ~0057373

Interestingly enough, it also did not create a new entry for the updated email address. Because it did actually match on the foreignkey, but then failed to update the record.

Fixed in next version

https://github.com/phpList/phplist3/commit/3349affc16f062dff7dcc130ad1c03af4c1f06bc