View Issue Details

IDProjectCategoryView StatusLast Update
0017944phpList 3 applicationMessage Send Processpublic25-11-15 15:37
Reporterjd440 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformanyOSanyOS Version
Product Version3.2.3 
Target Versionnext patchFixed in Version 
Summary0017944: line-break added by phplist 3.2.3 make impossible displaying in hotmail
Description
I just upgrade phplist from to 3.0.12 to 3.2.3 and I have big issue on hotmail

phplist beak all my HTML code adding a "=" to break the line as:

from :

                        <td width=3D"460" valign=3D"middle" align=3D"left" class=3D"full"><a style=3D"color:#db306f;" href=3D"http://www.mydomainewebite00.com?utm_source=3Demail50&utm_medium=3Demail&utm_content=3Dtext&utm_campaign=3Doffrr-noel-ide" ><img width=3D"460" height=3D"88" class=3D"full" style=3D"text-decoration: none; display: block; font-size:3em;font-weight:700;color:#e0e0e0; background-color:#db306f;border-style:none;" src=3D"http:/

to

                        <td width=3D"460" valign=3D"middle" align=3D"left" =
class=3D"full"><a style=3D"color:#db306f;" href=3D"http://www.mydomainewebi=
te00.com?utm_source=3Demail50&utm_medium=3Demail&utm_content=3Dtext&utm_cam=
paign=3Doffrir-noel-ide" ><img width=3D"460" height=3D"88" class=3D"full" s=
tyle=3D"text-decoration: none; display: block; font-size:3em;font-weight:70=
0;color:#e0e0e0; background-color:#db306f;border-style:none;" src=3D"http:/=


if there is no problem to diplaying the mail, in almost all mail client which understand this line break with "=", hotmail simply break the line.
And I guess in fact hotmail add " " after "=" becoming "= "

So id the line beak are inside a word we got for example:
"my word" => "my w= ord"

and if the line beak are inside a html balise we got for example:
"<img src="images/a.gif>" => "<img sr= c="images/a.gif>"



TagsNo tags attached.

Activities

michiel

23-11-15 19:40

manager   ~0057273

that's called quoted-printable encoding and phpList has always done that.

I suspect the problem is somewhere else. Can you outline how you compose a campaign?

Can you upload the plain-text content file of your campaign, so that I can try to replicate the problem?

jd440

25-11-15 15:33

reporter   ~0057303

Sorry I found it.
It was because this server need pop-Before-SMTP.

So You can Close.

Sorry About that.

By the way, I modify class.phpmailer.php in order to allow Pop-Before-SMTP.

Where can I purpose my modification?

michiel

25-11-15 15:37

manager   ~0057304

thanks. I'm puzzled how Pop-before-smtp would influence this, but it's fine by me.

PHPMailer is here: https://github.com/PHPMailer/PHPMailer