View Issue Details

IDProjectCategoryView StatusLast Update
0017942phplist applicationAll Otherpublic25-11-15 11:08
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.3 
Target Versionnext patchFixed in Version3.2.4 
Summary0017942: Use of short array syntax with php < 5.4
DescriptionRelease 3.2.3 and probably 3.2.2 had some changes applied by something called StyleCIBot that changed use of array() to [] in some files to do with the news sidebar.

https://github.com/phpList/phplist-ui-dressprow/commit/67a5e62fe371de56b497b773110bb29e25b00594

This syntax requires php 5.4 so the changes shouldn't really have been applied unless there is some validation to stop upgrading or installing with an earlier release of php.

The effect of the change when using earlier than 5.4 is a bit unclear. I noticed that the page footer was not being shown, nor the sidebar, as the html was cut-off, but people have reported other problems that might be caused by the page processing not completing.
TagsNo tags attached.

Activities

michiel

22-11-15 17:55

manager   ~0057266


Yes, the StyleCI wasn't as helpful as it claimed to be. I thought I had reverted them all, but clearly missed some.

Nevertheless, 5.3 is out of date now, and should be avoided. We should move towards an official "supporting 5.4 and up". But it will be good to announce that.