View Issue Details

IDProjectCategoryView StatusLast Update
0017918phplist applicationAuthentication Systempublic11-05-16 19:19
Reportermichiel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Version3.2.5Fixed in Version3.2.5 
Summary0017918: allow plugins to control authentication
DescriptionInstead of the auth.inc system, this should move to plugin capability.

See also.

https://github.com/phpList/phplist3/pull/25#issuecomment-149884081
TagsNo tags attached.

Activities

michiel

06-12-15 15:09

manager   ~0057377

branch, mantis 17918



https://github.com/phpList/phplist3/tree/mantis17918

michiel

17-04-16 12:05

manager   ~0057610

merged into master

gingerling

28-04-16 13:45

manager   ~0057684

So this makes SSO plugins easier to develop?

duncanc

28-04-16 14:36

developer   ~0057686

Last edited: 02-05-16 10:45

View 4 revisions

There appears to be something wrong with the implementation of this.

After upgrading my local installation, my super admin id wasn't allowed to edit admin details, not even my own id, on the List Administrators page.

I've just done a clean installation into an empty database and the same applies. The admin is not allowed to edit admin details.

It seems to be caused by the new auth plugin not being enabled automatically. Is that meant to happen somewhere?

Update - possibly caused by the admins.php page still referring to $admin_auth_module instead of the plugin.

Update - at one point the Manage Plugins page showed the phpListAdminAuthentication plugin as disabled. I enabled that plugin and now it is not listed.

See https://github.com/phpList/phplist3/pull/61 for a fix to the problem of not being able to edit admins, also to try to simplify the selection of the authentication class.