View Issue Details

IDProjectCategoryView StatusLast Update
0017896phpList 3 applicationMessage Send Processpublic29-10-15 12:17
Reporterdanwaterloo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformintelOSdebianOS Version
Product Version3.2.1 
Target Versionnext minorFixed in Version 
Summary0017896: Unable get lock for processing
Descriptioncan send a test message, but when processing queue from browser, message Unable get lock for processing shows up, and queue is never processed. This is on a shared host (by ipages.com), but no other phplist is running on this vm...
Steps To Reproducecreate new campaign, send test to email address, it arrives.
submit this campaign to the queue, to a list with one address: the test email address
process queue, and get "Unable get lock for processing" message, and queue is never sent.
Additional InformationI used the same files on my own installation (centos 5, php v 5.5.x) and all went well. I ftp'd the files of this installation to the ipage.com hosted account, and get this message. (php v 5.3.x) when changing to 5.5 on the ipage.com site, I get a 500 page error.

I'm thinking this could be the server issue, or an issue with php on debian...
TagsNo tags attached.

Activities

danwaterloo

24-10-15 12:21

developer  

michiel

26-10-15 14:50

manager   ~0057084

it should time out after a little while and work again. Does it display the message continuously?

danwaterloo

26-10-15 15:00

developer   ~0057086

no, it never times out. this is a 'shared server'... could it be some other machine is running phplist and we cannot see it? or... would a needed debian command not be available?

I can get in the server to alter the php files if you need me to test anything.

danwaterloo

27-10-15 03:52

developer   ~0057089

more info:
changed the php max_memory from 32M to 128M, and then an error started showing up : Database error 1146 while doing query Table 'xxxxx.phplist_sendprocess' doesn't exist.

somehow (?) that table as well as phplist_message_attachment, restored from a backup.

Now the 'cannot get lock' message is gone, but the emails are still not being sent.

michiel

27-10-15 16:01

manager   ~0057090

sounds like more tables might be missing?

danwaterloo

27-10-15 23:52

developer   ~0057094

I checked all the tables via the menu in the web interface and all is good

michiel

28-10-15 09:10

manager   ~0057095

are they still not being sent? Can it be some other reason, unrelated to the original report?

danwaterloo

29-10-15 12:14

developer   ~0057109

the system is working ok, but stops sending after a couple of emails.

it appears that this install is on a shared server, and the server hosting company has limited the sending of emails.

for future note:
it's ipages.com, they limit to 2000 emails/day on the shared servers.

Consider this case closed.