View Issue Details

IDProjectCategoryView StatusLast Update
0017848phplist applicationAuthentication Systempublic28-09-15 14:01
Reporterdanwaterloo 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformapple/osxOSosx/mampOS Version10.10.5
Product Version3.2.0 
Target VersionFixed in Version3.2.1 
Summary0017848: continuously logged out when on IPv6 connection
DescriptionAfter logging in to phpList on localhost, would select a page from menus, and would be logged out and back at the login page. Login again, and then arrive a selected page.
Steps To ReproduceAppears to be some kind of ipV6 conflict, with ip's changing.
had my computer on a lan with ipv6 activated.
Additional InformationSeemed to be related to ipV6 and ipV4, in that there was a localhost defined for both. The system seemed to be switching between ipV4 on the login, and ipV6 when going to the next page, and since the 'ip address changed', would be logged out.
had to change the hosts file as follows to stay logged in:
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost Daniels-MacBook-Pro.local
255.255.255.255 broadcasthost
# next line was original setting, now commented out
# ::1 localhost
::1 localhost-ipv6
fe80::1%lo0 localhost-ip
TagsNo tags attached.

Activities

michiel

28-09-15 13:59

manager   ~0056900

it's not the "Ip address has changed" error. The IP detection was Ipv4 only.

this should fix it:

https://github.com/phpList/phplist3/commit/403aed92dbf096ede702a8feabdf1cb08e497ac9