View Issue Details

IDProjectCategoryView StatusLast Update
0017806phplist applicationInterface - Administratorpublic10-09-15 16:39
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.0-RC1 
Target Version3.2.0Fixed in Version3.2.0 
Summary0017806: The "phplist hosted news" is distracting
DescriptionThe new "news" section is distracting as the font of the text is larger than the other page text. Also six items in four months probably doesn't really qualify as news.

I suggest displaying only on certain pages, say the home page so that it is displayed on logging-on but not elsewhere.

The title is misleading as it is showing an RSS feed from phplist.org not phplist.com.

To display only on the home page change line 3 of admin/ui/dressprow/rssfeed.php to

if (isset($_GET['page']) && $_GET['page'] == 'home' && !empty($_SESSION['adminloggedin'])) {

The font is too big because all the RSS items are formatted as h3 elements.
h3 is used for the heading of the side-bar, but shouldn't then be used for the individual items. They can just be styled as a div or similar.

Changing line 23 as follows makes the display much more consistent:

      <div class="entry-title"><span class="updated published">'.$date.'</span> '.$item['link'].'?utm_source=phplist-'.VERSION.'&utm_medium=newspanel&utm_content='.urlencode($item['title']).'&utm_campaign=newspanel</div>
TagsNo tags attached.

Relationships

related to 0017810 resolvedmichiel phpList Internationalisation CSS phplist hosted news 

Activities

duncanc

30-08-15 11:07

developer   ~0056710

I have just logged-in to my phplist hosted account and the news block is displayed only on the home page (called Dashboard), not on other pages.

So I am wondering why it is appearing on all pages in the new release?

michiel

31-08-15 18:00

manager   ~0056711

the content on the hosted vs download listing is different.

support

07-09-15 14:30

administrator   ~0056730

yes, I agree. This needs to be cleaned up a little before release

michiel

07-09-15 20:38

manager   ~0056744

I have changed:

1. made the fonts smaller
2. only display on a few pages, not all

http://dev.phplist.com/lists/admin/?page=home

comments?

duncanc

08-09-15 18:19

developer   ~0056757

This looks better now.

But I think that once this is released people will ask how to disable it. Has that happened with hosted?

support

09-09-15 09:12

administrator   ~0056758

No, people don't seem to mind it. It's different in hosted though as the news is totally different, and it doesn't link to articles in the same way. The long and short of it for now if you cant disable it, I suppose! :)

gingerling

09-09-15 09:17

manager   ~0056759

sorry, that was me btw - was logged in to wrong account