View Issue Details

IDProjectCategoryView StatusLast Update
0017790phpList 3 applicationCampaign Managementpublic11-08-15 10:19
Reportersd3pk3 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.12 
Target VersionFixed in Version 
Summary0017790: Edit sent campaign creates draft can not be sent and overwrites old campaign
DescriptionIf you edit a sent campaign (in order to the text as template for a new project), it creates a draft and the old newsletter is removed from the list of sent messages. But this draft has the same ID like the sent message, so this new campaign can not be sent out again. Instead, the old content from the previous sent campaign is overwritten everywhere in PHPList (section user history messages, statistics).
Even sending start/stop notifications are sent out, but no newsletters are sent.
Steps To Reproduce1. Create a campaign and send it.
2. Go to the list of sent campaign and edit the campaign
3. Try to send this campaign (with changed text) based on the old one and try to send it
TagsNo tags attached.

Activities

michiel

11-08-15 08:44

manager   ~0056592

that is how it is intended to work. Once a campaign has been created and sent, you should not change the content and resend it. It will not go out to your subscribers. You need to create a new campaign.

gingerling

11-08-15 10:19

manager   ~0056598

Indeed, there is more information about this in the manual at phpList.org