View Issue Details

IDProjectCategoryView StatusLast Update
0017754phplist applicationAll Otherpublic19-09-16 17:30
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.12 
Target Version3.2.6Fixed in Version3.2.6 
Summary0017754: subscriber list information should be maintained when they unsubscribe
DescriptionWhen a subscriber unsubscribers their list membership information is deleted. It would be better if it were maintained.
TagsNo tags attached.

Relationships

related to 0017753 resolvedNYChris phplist application Subscriber profile does not record list membership so after unsubscription there is no record 

Activities

gingerling

15-07-15 14:12

manager   ~0056450

https://github.com/phpList/phplist3/commit/28e8161b27153259f3f35aedebf044f9dda00caa

duncanc

19-07-15 15:36

developer   ~0056495

This is going to cause a problem with the count of confirmed / unconfirmed subscribers shown on the lists page. The code in admin/lists.php has a comment

  ## same with blacklisted, but we're disregarding that for now, because blacklisted subscribers should not
  ## be on the list at all.

It is straightforward to count the number of confirmed and not blacklisted, etc.subscribers using sql similar to this

select
sum(1) as subscribers,
sum(if(confirmed = 1 && blacklisted = 0, 1, 0)) as confirmed,
sum(if(confirmed = 0 && blacklisted = 0, 1, 0)) as notconfirmed,
sum(if(blacklisted = 1, 1, 0)) as blacklisted
from phplist_user_user

michiel

20-07-15 11:10

manager   ~0056496

yes, that's a good point. we may need to review other places as well. It would eg not be popular if it drops the statistics because we're dividing by a bigger number.

duncanc

02-03-16 12:13

developer   ~0057546

This change has already been applied and the member counts on the Lists page are misleading. The 'confirmed' total includes those who are also blacklisted, so does not reflect the number of people who would be send a campaign.

See pull request https://github.com/phpList/phplist3/pull/50