View Issue Details

IDProjectCategoryView StatusLast Update
0017751phplist applicationInterface - Administratorpublic12-05-17 22:12
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.12 
Target Versionnext patchFixed in Versionnext minor 
Summary0017751: Use of descendant selector on Compose tab
DescriptionThere is a css rule used on each of the tabs when composing a campaign

body.send .panel .content div { margin:5px;}

This is in file ui/dressprow/css/style.css. I think that the purpose is to provide spacing for the subsections on each tab.

Being a descendant selector the rule has an unintended effect on the TinyMCE editor.
The editor uses div elements for its toolbar and buttons and those are
affected by the css rule with the effect of making the buttons and toolbar too large.

Can the rule be changed either to use a class on each div, or make it more specific?

When I developed the TinyMCE plugin the toolbar looked ok, so I guess that the css has changed since then.
TagsNo tags attached.

Activities

michiel

13-07-15 07:37

manager   ~0056407


tarek, can you shine a light on that?

michiel

12-05-17 20:48

manager   ~0059059

duncan is this still an issue? Mariez, can you have a look?

mariez

12-05-17 20:52

developer   ~0059060

Sounds like a quick fix. Will take a look tonight.

duncanc

12-05-17 22:10

developer   ~0059061

I worked around the problem by having the plugin add some more-specific css that sets the margin, so I think that this issue can be closed now.

mariez

12-05-17 22:12

developer   ~0059062

Thats great duncanc. thanks!