View Issue Details

IDProjectCategoryView StatusLast Update
0017646phpList 3 applicationBounce Managementpublic08-07-15 09:06
Reporterbst2002 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.0.10 
Target Versionnext minorFixed in Version3.2.0 
Summary0017646: Advanced Bounce Processing Rules match headers
DescriptionHallo,

sometimes Auto-Reply or Vacation (etc.) Bounce-Emails do not have any Body.
So i can use an regex to match "empty" Body, but what about extending Rules to match Email-Headers?
TagsNo tags attached.

Relationships

duplicate of 0016909 resolvedmichiel does not pick up regular expression 

Activities

bst2002

16-04-15 11:41

reporter   ~0056013

Applying Bounce-Rules also on the Email-Header could be advantage in processing Vacation and other Auto-Reply Emails where the Body varies every time and/or to much but the Header not (has always the same for ex. "Delivered-To: Autoresponder" or "Subject: Re: ....")

bst2002

16-04-15 11:44

reporter   ~0056014

Hmm, what about combining "Rules-Body" "logic and" "Rules-Header"?
Say, if a Header-Rule match and a Body-Rule then take action...

michiel

16-04-15 11:50

manager   ~0056016

I think there is an issue on this already

bst2002

16-04-15 12:27

reporter   ~0056017

Another Variant could be to have an Selector on every Bounce-Rule.
Applay Rule on Body or Header or Header+Body....

ex:

$rule = matchBounceRules($row['data'],$bouncerules);
or
$rule = matchBounceRules($row['header'].$row['data'],$bouncerules);