View Issue Details

IDProjectCategoryView StatusLast Update
0017637phpList Internationalisation[phpList 3 application] Internationalization (l18n)public03-08-18 12:53
ReporterHenk van Dijk 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version[phpList 3 application] 3.0.12 
Target Version[phpList 3 application] Future developmentsFixed in Version 
Summary0017637: Language in browser sticking to English
DescriptionHad Installatron automatic installing phpList. Went fine.

Asked them once to update the picture from phpList in their Installatron one-click webinstaller, since the picture they use is a picture of the former release. No luck tough. Another thing is that I can not choose my language in which phpList is installed. The list is not complete.

So I choose English. After the installation I was able to download the Dutch translation and the program displays this well. But after login out, and logging back in the translation is reset to English once again.

Any idea how to fix this? Never tried installing in English and after that switching to Dutch, but I thought this might be an issue.

I'm using Firefox, but tried this also in IE with the same result.
TagsNo tags attached.

Activities

michiel

21-05-15 14:14

developer   ~0056133

I'm not entirely sure how to replicate this. What is the exact issue here? That phpList is in english and you cannot switch language? Is it installatron specific?

Henk van Dijk

01-06-15 07:22

reporter   ~0056186

Hi Michiel, I think it is Installatron specific. Made contact with Installatron also because they only support some of our translations, among them Dutch seems not to be supported. So I contacted Installatron with a request to update their systems (translations as well as the old picture of phplist version 2 used) two times. No response. Updating from one version to another is going fine though. In the meantime I solved my problem by setting the config.php as follows:


$language_module = 'dutch.inc';
$default_system_language = 'nl';

So your questions: I was able to switch to dutch, but after loggin out, and login in the translation was set back to english. Again I was able to set this back to dutch, but after each logging in i had to set it back.

Issue History

Date Modified Username Field Change
08-04-15 11:07 Henk van Dijk New Issue
21-05-15 14:14 michiel Note Added: 0056133
21-05-15 14:14 michiel Status new => feedback
01-06-15 07:22 Henk van Dijk Note Added: 0056186
01-06-15 07:22 Henk van Dijk Status feedback => new
05-10-15 12:06 michiel Target Version => Future developments
03-08-18 12:53 suela Status new => resolved
03-08-18 12:53 suela Resolution open => fixed
28-08-18 00:35 Mobarak Issue cloned: 0019389