View Issue Details

IDProjectCategoryView StatusLast Update
0017624phplist applicationUser Managementpublic06-07-15 18:04
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.12 
Target VersionFixed in Version3.2.0 
Summary0017624: Subscriber profile page does not update date attribute that has spaces in the name
DescriptionA problem reported in the user forum to do with the Subscriber Profile page.
Updating a date attribute whose name includes spaces does not work.

https://forums.phplist.com/viewtopic.php?f=35&t=42211

This seems to be caused by the phplist attribute name being used for the html name attribute, and somewhere along the line spaces are changed to '_'.

This change seems to fix the problem but it would be better to avoid using the attribute name and use the attribute id instead.

file admin/commonlib/pages/user.php

change line 136 from
             $value = $date->getDate($attname);
to
             $value = $date->getDate(normalize($attname));
TagsNo tags attached.