View Issue Details

IDProjectCategoryView StatusLast Update
0017623phpList 3 applicationEmailpublic28-11-15 17:15
ReporterCraigL 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionfixed 
PlatformAWS EC2OSCentos LinuxOS Version6.6
Product Version3.0.10 
Target Versionnext minorFixed in Version 
Summary0017623: Test email from Campaign Template editor fails
Description'Send test message' button at the bottom of the add/edit template screen does not work unless that template is set as the 'System Template' (on the Manage Campaign Templates screen).
Email sending from various other points in the application work without issue.
Email sending from the 'system template' works without issue.
Steps To ReproduceSelect a template to edit.
Enter a valid email address in the 'Send Test' edit box.
Click Send test message.
Messages returned:

Template Saved
Sending test

No email is sent.
TagsNo tags attached.

Activities

michiel

20-05-15 17:32

manager   ~0056123

ah, it appears this hasn't been coded yet.

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/template.php#L236

michiel

07-07-15 13:13

manager   ~0056344

sending a test from template editing only works for the system template. This is now made more clear when trying to send a test.

gingerling

07-07-15 17:33

manager   ~0056348

Can we make it work so tests can be sent from non system templates?

support

10-07-15 23:05

administrator   ~0056385

Just to clarify the fix, do tests now send from all templates? (can't send from sneakpeek to check)

michiel

11-07-15 11:30

manager   ~0056397

no, sending tests only works from the system template. In that case it will send three test emails:

1. Request for confirmation
2. Welcome to our newsletter
3. Goodbye from our newsletter

support

11-07-15 11:30

administrator   ~0056398

So this issue is not resolved then...

michiel

11-07-15 11:46

manager   ~0056399

yes, it is, it will now explain it doesn't work, instead of just not working.

gingerling

25-08-15 16:08

manager   ~0056652

Yeah, we need to just remove this. It's not in any way fixed. I tested the thing and you get a message at the top of the page for a few seconds that says something confusing.

I suggest either:

1) remove text box from the template page or
2) make the test box work