View Issue Details

IDProjectCategoryView StatusLast Update
0017606phplist applicationSubscribe Processpublic06-07-15 17:04
Reporterjszopa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.12 
Target Version3.0.XFixed in Version3.2.0 
Summary0017606: After unsubscribtion user will be blacklisted
DescriptionHallo,

i use the version 3.0.11 and today i try 3.0.12.
My problem is:
If a user unsubscribe with the unsubscribeurl (http://localhost/lists/?p=unsubscribe&uid=7f8a6223cf8957fd254dae5f702f57f2.), he will be blacklisted.
After a resubscription and confirmation he stay blacklisted.

How can i reach that a user will be deleted if he unsubscribe?
Or how can is reach that the resubscription works?

Thanx
Johannes
TagsNo tags attached.

Relationships

related to 0017513 resolvedmichiel When [CONFIRMATIONURL] (?p=confirm) is loaded, PHPList should check if user is NOT confirmed **before** sending welcome email ag 

Activities

michiel

11-02-15 08:20

manager   ~0055928

are you sure? When a subscriber uses the normal confirmation system, they should be removed from the blacklist again.

Anna, can you replicate this?

michiel

11-02-15 12:57

manager   ~0055929

ok, managed to replicate this.

If the subscriber is still marked confirmed, but blacklisted and then re-subscribes, they are not unBlacklisted again.

duncanc

27-02-15 12:23

developer   ~0055951

This seems to be a consequence of the change made for issue 17513
https://mantis.phplist.com/view.php?id=17513

In that change, the test for already being confirmed could be limited to only the sending of the confirmation email, all the other processing could still be done.

Or change the test from "unconfirmed" to "blacklisted or unconfirmed", which I think would then handle the case in this issue.