View Issue Details

IDProjectCategoryView StatusLast Update
0017576phpList 3 applicationInternationalization (l18n)public13-02-19 12:38
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0017576: Can we set up a DB query script to get a list of people who have contributed via pootle
DescriptionAt the moment translators are left out of the thank you notes in release blogs because pootle does not tell us who/when they have contributed. I have checked via the IRC and they said the only way to get a list of who has made a contribution is to do a database query.

I wonder if we can have a script that can get me the data from the pootle db when we make a release, and so I can include these contributors with everyone else?


TagsNo tags attached.

Activities

rata

13-01-15 16:02

updater   ~0055853

Again, I'm quite busy this week. Should I drop something to give this a try ? Or should I finish all I have this week and if there is time to spare, try to squeeze this in?

gingerling

13-01-15 16:24

manager   ~0055856

I will need this before we release 3.1.0 - so keep an eye out for that, but say, 3 weeks?

rata

15-01-15 12:52

updater   ~0055869

ok.

In any case, I'm against doing it like that. If they don't provide a way to do it, nor a stable API to consult it, then when we upgrade it will probably be broken the way we do to query it. **We** will need to fix it, etc. It's too fragile to do it like that, it's against all "best practices", and will only make more difficult for us to upgrade when they release a new version (and sometimes is important to upgrade on a timely fashion, because of security releases).

If we do it, it will create a dependency for us on that, and we don't want to depend on something so fragile IMHO.

support

15-01-15 12:55

administrator   ~0055870

Is there not an API then?

support

15-01-15 12:55

administrator   ~0055871

https://pootle.readthedocs.org/en/stable-2.5.1/api/index.html

rata

15-01-15 12:57

updater   ~0055872

No, doing a query to the DB is not an API.

Probably what should be done is a proper patch (or report a bug so someone does the patch) to show the contributors to a certain project between to given dates. But, that is not easy, of course :)

rata

15-01-15 12:57

updater   ~0055873

s/to given/two given/

rata

15-01-15 13:04

updater   ~0055874

Oh, I found one API for the version we are using (not a development version, as the other APIs I found were), but doesn't seem to support asking the list of contributors. So, it seems it doesn't help at all. Probably a patch to expose that on the API is needed, but might be not a trivial task either.

gingerling

10-09-15 14:30

manager   ~0056766

Hi.

Still is still an issue for me. Essentially at the moment, we cannot tank translators the same as we thank everyone else. Can you see if the new versions of pootle have addressed this issue? They have been promising it for ages.

rata

10-09-15 16:29

updater   ~0056776

PLEASE assign the issue, it's not unlikely that I won't look at issues if you don't assign it to me.

There is a new version of pootle, which is a PITA to upgrade and have removed many features (some of which will be added back in future releases) and was heavily changed, so we probably will need to change a LOT to upgrade to that version. That being said, it's planned to upgrade to pootle, although it seems this version doesn't add support for what you say:

http://docs.translatehouse.org/projects/pootle/en/stable-2.7.0/releases/2.7.0.html

(as far as I see).

You may want to open a github issue for them on that and, that way, we can know when it's fixed.

Also, please have a look at the removed features:

http://docs.translatehouse.org/projects/pootle/en/stable-2.7.0/releases/2.7.0.html#removed-features

And let me know if it's ok for our use case if those features are not available or if we really need some of those.



Thanks a lot,
Rodrigo

gingerling

10-09-15 16:32

manager   ~0056777

" You may want to open a github issue for them on that and, that way, we can know when it's fixed."

I have asked the developers before and they said

1) no, we won't add this now, but it's planned for sometime (but we are still waiting) and
2) This is easy, just make a SQL query. I am not really understanding why there is an issue with making a SQL query as they suggest.

rata

10-09-15 16:42

updater   ~0056779

Well, opening a bug report it's a nice way to see when it is fixed. I really really think you should do it if you want it.

I don't know which query is it that you want to run. But maybe it's not too difficult via a query.

But I don't want to DEPEND on that query, on ANY way. So if we upgrade pootle and the feature is not there and the query stops working or is not possible to do it easily with the new db format, we won't be able to run it unless we invest some time. And I don't want to be "in a hurry" because we need to release and we CAN'T do it without this info.

So, we MAY be able to do they query once or twice. But it will probably break on upgrades (they are rewriting everything and changing A LOT internally), and I don't want to be in this rush with a release or anything.

So, if you haven't already, please report it ASAP so they can fix it. And we can upgrade without problems because the feature we need is there.

rata

10-09-15 16:43

updater   ~0056780

Of course, we can write the patch too. But it will take some time (not easy AT ALL to estimate) to do it.

gingerling

11-09-15 12:16

manager   ~0056801

better ask M about the features, I don't know much about the software at all and don't use it.

I will ask again/do a feature request as you suggest.

gingerling

11-09-15 13:46

manager   ~0056802

Ok rata,

Here is where they told me to wait for 2.7 - https://github.com/translate/pootle/issues/459 this is now here, but I don't know if they made this feature or not. there is another example here of them saying "Just make a database script" (though it's not the time I was referring to).

I have also added to this report https://github.com/translate/pootle/issues/3932 which would solve our issue just fine too.