View Issue Details

IDProjectCategoryView StatusLast Update
0017545phpList 3 applicationMessage Managementpublic11-07-15 11:28
Reportergingerling 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version3.0.10 
Target Versionnext minorFixed in Version 
Summary0017545: Uncategorised lists, confusing name? Could we have a search?
DescriptionUncategorised lists seems is a little confusing, we have a few note this in the manual testing:

it sounds like it would show all lists regardless of category, but actually it shows lists that are not yet categorized. There MAY be a translation issue?

Assuming showing all lists regardless of categeory would max out page, perhaps we could have a search? So you can search for list names.
TagsNo tags attached.

Relationships

related to 0017467 resolvedmichiel phpList 3 application categorise lists from lists menu dumps user in settings, should go back to lists 
related to 0017465 closedxheni phpList 3 application delete category once a list is assigned to it 
related to 0017546 resolvedmichiel phpList 3 application categorise list page - re-edit option 
child of 0017526 assignedgingerling phpList 3 application some bugs from bjorn while he was correcting the manual (with a lot of additions from anna) 

Activities

michiel

21-05-15 20:28

manager   ~0056151

not sure this is still necessary. I'm hiding the dropdown if there are no categories set up.

gingerling

22-05-15 09:06

manager   ~0056155

I think a search would be really great if it's possible

michiel

08-07-15 07:56

manager   ~0056356

I don't see why "Uncategorised" showing "all lists that are not yet categorised" is confusing.

That is exactly what the term means.

gingerling

08-07-15 08:19

manager   ~0056357

It could be misunderstood as show "show me lists regardless of category" - I think it's partly because of the nature of the dropdown.

It defaults to "uncategorised" and then from there you zero in on a category. I would assume that this works just like in WordPress, where they have "All categories" by default and then you zero in by using the dropdown to filter by category. Indeed in WP there is no way to show posts with no category usin the filters (though there are posts with no category) - you would have to use the search. The same for dates, "all dates" or June 2015, July 2015 etc.

I can see that the meaning of uncategorised could be interpreted "your way", and that may even be more sensible if someone knows phpList well, however "my way" is also plausible as a meaning, especially in the context of other software like WP, and the this issue did come up in the documentation process as a point of confusion.

We could perhaps change the text? Not sure what too though... Maybe "Without Category?"

I do think a search would really help clarify the situation. Then you would have

All lists, Uncategorised lists, categories... and a search bar next to it.

Realistically, the issue here is that there is a bug in that phpList can't display enough categories right? Maybe we should fix that, have a search, and then all will be more standardised :)

michiel

08-07-15 10:59

manager   ~0056364

the reason to have categories is that the "list" page is very slow when the number of lists increases. So, I would want to avoid an "All" option.

gingerling

08-07-15 11:57

manager   ~0056368

Yeah, I know that's what I mean by bug.... Is there nothing to be done about that? It seems to me like Categories are useful in their own right, but that view all is just a normal sensible thing to have. In WP they just have a "next 10" system, like we have for campaigns. Can't we do that?

michiel

08-07-15 12:16

manager   ~0056369

that already happens automatically when you have more than 50 lists. I'll drop that to 30.

gingerling

09-07-15 08:55

manager   ~0056375

Sure or even 5 or 10? The system for campaigns sorting is great (see image).

Also I notice it says "filter" so I never used it, but it's actually a search for the title of the campaigns, which is really awesome.

gingerling

09-07-15 08:57

manager  

campaigns.png (5,001 bytes)
campaigns.png (5,001 bytes)

support

10-07-15 23:01

administrator   ~0056384

mmm, odd, so if you have more than 30 lists it groups them into 10's.... why not just group them when there are more than 10! :D

michiel

11-07-15 11:27

manager   ~0056396

because it's annoying to have them in two pages when there are eg 19, and you would want to have them all in one page. But this page is slow once there are a lot of lists. That's something else I should work on.