View Issue Details

IDProjectCategoryView StatusLast Update
0017513phplist applicationSubscribe Processpublic06-10-15 14:03
Reporterairelle 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.10 
Target Versionnext minorFixed in Version3.2.0 
Summary0017513: When [CONFIRMATIONURL] (?p=confirm) is loaded, PHPList should check if user is NOT confirmed **before** sending welcome email ag
DescriptionA confirmation email is sent to the list manager and to the subscriber **each time** he loads the [CONFIRMATIONURL] which is included in the message sent upon subscription (the link looks like www.mydomain.com/lists/?p=confirm&uid=XXXX).

Some users forgets to close the tab in their navigator and each time they launch it, the confirmation emails are sent again, and again and again. I received some of them 6/7 times... and with hundred of new subscribers each day, it's really a problem...

Would it be possible to **check** if the user has already confirmed his subscription **before** that PHPList send confirmation emails (and do nothing if the user has already confirmed) ??
Steps To Reproduce- a new user subscribe to a newsletter
- he receives a welcome message which contains the [CONFIRMATIONURL] link (www.mydomain.com/lists/?p=confirm&uid=XXXX)
- each time he clicks on this link, the confirmation process is run and an email il sent to him, an email is sent to the list manager.
TagsNo tags attached.

Relationships

related to 0017528 resolvedmichiel Multiple unsubscription notifications for the same subscribers 
related to 0017606 resolvedmichiel After unsubscribtion user will be blacklisted 
related to 0017859 new Subscribed lists missing 

Activities

michiel

29-10-14 22:30

manager   ~0055582


yes, good point

duncanc

19-03-15 09:11

developer   ~0055977

There is a further problem with the solution to this issue, reported on the user forum https://forums.phplist.com/viewtopic.php?f=37&t=42219

When someone who is already confirmed signs up using another subscribe page that offers a different list then he will not be sent the "welcome" email, because he is already confirmed.

The real cause of the problem seems to be that phplist doesn't hold confirmed/unconfirmed against each subscribe page/list, so I don't see how it can distinguish between the cases of clicking the same confirmation link again, or clicking a confirmation link that is for a different subscribe page/list.

The original issue, of receiving repeated welcome emails, although annoying, seems less of a problem than not sending the welcome email at all after subscribing to a separate list.

michiel

19-03-15 17:22

manager   ~0055979

Maybe we need to add a timeout. Eg when the last confirmation was sent more than X minutes ago, we can send it again.

That doesn't help though when the page is reloaded on a browser session restore.

michiel

08-07-15 12:35

manager   ~0056371

the confirmation is now remembered in the session with "subscriberConfirmed" which is cleared on the subscribe page, so that it will work with a new subscribe page