View Issue Details

IDProjectCategoryView StatusLast Update
0017493phplist applicationphpListpublic17-12-14 17:42
Reporteroboumati 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux ServerOSDebianOS VersionSqueeze
Product Version3.0.10 
Target Version3.0.XFixed in Version3.0.11 
Summary0017493: mysql_affected_rows() function not found
DescriptionWhen $database_module is set to "mysqli.inc" in confg.php, an error occured in sessionlib.php on line 69 because the function mysql_affected_rows() is not defined.

It should be replace by sql_affected_rows() which is defined in mysql.inc and mysqli.inc regarding the choice made in the configuration file.
Steps To ReproduceSet
$database_module = "mysqli.inc";
in config.php
TagsNo tags attached.

Activities

michiel

23-10-14 11:39

manager   ~0055495

where does this have an effect? which pages go wrong?

oboumati

23-10-14 13:12

reporter   ~0055499

If $SessionTableName is set to a table name and $database_module is set to "mysqli.inc" in config.php, to store session in database, all pages using session goes wrong.

michiel

23-10-14 13:22

manager   ~0055500

ah, interesting. I haven't used the DB based sessions for years. It used to be a Webbler related feature.

oboumati

23-10-14 15:00

reporter   ~0055524

In all my projects, as soon as possible, I prefer the DB based sessions.
Except this error, it works well ;-)