View Issue Details

IDProjectCategoryView StatusLast Update
0017465phpList 3 applicationAll Otherpublic01-11-18 14:20
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0.8 
Target Version3.4.0Fixed in Version 
Summary0017465: delete category once a list is assigned to it
DescriptionIf I create a category in the settings page and then assign a list to it, then delete the category, it does not get removed from the lists page/system - list is still only visible under the category.

If I go to categorize lists the list assigned to the deleted category is not there (even if it is allready assigned it should be there anyway so I can change assignment??) and when I click configure categories the deleted category is back in the list of categories again.

The ONLY way I have managed to fix this is to edit the list itself to remove the category there, only then does the category become deleted, but it is still listed in the dropdown when creating a new list.

So, it is possible, with a LOT of editing to delete categories (sort of)but it's hard work if you have say, 30 lists and you have to edit every one to remove it's category as well as deleting the categories from the settings page.
TagsUI Improvements

Relationships

related to 0017546 resolvedmichiel categorise list page - re-edit option 
related to 0017545 resolvedmichiel Uncategorised lists, confusing name? Could we have a search? 
related to 0017467 resolvedmichiel categorise lists from lists menu dumps user in settings, should go back to lists 

Activities

michiel

24-11-14 11:21

manager   ~0055721


that's debatable to be a feature or not. As it is, you need to think carefully about your category assignments. Once a list has a category, you can edit it when editing the list.

gingerling

24-11-14 12:38

manager   ~0055724

To me, this seems like a bug.

I think, if you delete a category, all the lists should simply become "uncategorised" - like with wordpress tags, if you edit or delete a tag.

What we need is a fluid situation (you have mentioned whatsaspp etc) but this is very brittle in nature, you have to do things in an exact order or it does not work/becomes very confusing. I am sure there are many other ways to break this process that I have not done.

michiel

08-07-15 07:53

manager   ~0056355

you can now do this with the re-edit option.

support

10-07-15 22:41

administrator   ~0056381

There is an odd effect now

1) categorise some (not all) your lists
2) go to the categorise lists page and the uncategorised ones will show there
3) go into config > settings and delete one of the categories
4) Open the categorise lists page again, the newly uncategorised ones (as category is deleted) do not show up
5) click re-edit, and those lists have "choose category" next to them along with all other uncategorised lists

support

10-07-15 22:49

administrator   ~0056382

Additionally, the deleted category still shows up on the subscribers > subscriber lists dropdown menu, and the lists still remain categorised there.

There still seem to be many random bugs when you delete a category.

I know in theory categorisation should be a well designed process, but just look at out mantis... life don't work that way. People need to be able to delete categories, and all lists in that category should become uncategorised automatically.

michiel

11-07-15 11:24

manager   ~0056394


make that a feature request related to this one:

removing a category needs to force assigning a new one

Things is, the list page will show all categories of lists, and the category is remembered per list. You can remove them now, so the issue is resolved as it stands.

support

11-07-15 21:25

administrator   ~0056401

I do like this new re-categorise feature, I think it's great, but I don't feel this bug is solved. The initial report was:

"If I create a category in the settings page and then assign a list to it, then delete the category, it does not get removed from the lists page/system - list is still only visible under the category."

This is still exactly the situation we have now, actually, now it's a little worse because you are left with a category sitting in your lists page that no longer exists in your setting page. Before the category would re-appear in the settings page when you refreshed.

We have made it easier to re-categorise lists, and that is great, but the only issue it solves is this one:

"The ONLY way I have managed to fix this is to edit the list itself to remove the category there, [...] So, it is possible, with a LOT of editing to delete categories (sort of)but it's hard work..."

Because now you can edit the list categorisation in bulk rather than having to go to the list page.

So basically the bug has been made easier to deal with, but not removed.

michiel

11-07-15 22:08

manager   ~0056403

yes, I agree it's not been resolved, which is why I wrote "add a new one to address that".

The main reason to add a new one, and not keep this one is so this one is listed in the changelog for 3.2

maybe change the subject of this one, which is not that great anyway, as it's a question, and not a statement.

gingerling

13-07-15 10:08

manager   ~0056413

I don't see why to add a new one: the bug you have actually solved is here: https://mantis.phplist.org/view.php?id=17546

This bug is not solved. We don't need to duplicate it. It just doesn't get listed in 3.2 unless it is fixed in 3.2.

michiel

13-07-15 10:17

manager   ~0056415

ok