View Issue Details

IDProjectCategoryView StatusLast Update
0017419phplist applicationAll Otherpublic16-10-14 16:11
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version3.0.9Fixed in Version3.0.9 
Summary0017419: Adding template chapter, confusion with images
DescriptionSo this is one problem I have been stuck on for weeks

I have been working on this chapter about templates with Mariez http://booki.flossmanuals.net/phplist/_draft/_v/1.0/templates/

I am using the phpList announcements template
The Download version of phpList on Dragonriders server
I am uploading the template from a file (attached)


The template has an image in https://www.phplist.com/images/logo-gen.png
When I add the template it asks me if I want to upload the images in the list below, but no images are listed
When I send a test using the template no image is visible, just text
TagsNo tags attached.

Relationships

related to 0004221 resolvedmichiel PHPList - Edit Template Problem 
related to 0017475 resolvedmichiel template upload and images - remove the no-images step alltogether 

Activities

gingerling

25-09-14 19:20

manager  

phpList_template.html (2,261 bytes)

michiel

25-09-14 19:26

manager   ~0055162

not good to be stuck for weeks!

michiel

25-09-14 21:03

manager   ~0055163

the reason is that the image exists, so there is no need to upload it.

michiel

25-09-14 21:03

manager   ~0055164

so, not a bug, but intended functionality.

mariez

26-09-14 00:28

developer   ~0055165

" When I send a test using the template no image is visible, just text"

But I can see the image in the template you attach here.
You have to be connected to see it, because the img source is the address of an online image. If you are connected and still don't see the image, send me a test to me, so i can take a look to the code of the mail you sent.

gingerling

26-09-14 11:22

manager   ~0055167

mmm, today I see the image. I haven't even rebooted my machine over night - yesterday it simply was not there in any email...

anyway

M: the reason is that the image exists, so there is no need to upload it.

The I don't understand this. The image is linked with the src tag thing as any image in any template would be. So, what other way could this situation unfold? What is the point of the add image screen?

Mariez: thanks I will let you know if this happens again. It was very strange, I was looking at it for a long time, trying to find why this image would not work, and then today it did, but I had not changed anything I don't think...

michiel

26-09-14 11:31

manager   ~0055168

The page will only ask to upload images that don't exist. If the image is linked with src to a remote location and it exists, there, it will not ask to upload it.

Now, change the code to refer to a non-existing image and try again.

gingerling

26-09-14 13:33

manager   ~0055171

mmm yes I see. It's very confusing though, especially as there are check boxes on the page before about checking images having full url etc that seem to not relate to this but sound like the might.

Also, it's confusing because I am not sure how it would be used correctly

in this case I changed the image url to http://www.phplist.com/images/NAMEY_NAME.png" which does not exist

I upload a random picture when prompted

then when I send a test email using that template I get THIS code

href=3D"http://www.phplist.com/"><img alt=3D"phplist.com" style=3D"borde=
r: 0px;" src=3D"cid:c240cd81c8a9bbd9285ad9ab85cfae47" /></a></td>

which gives me the image attached (what is it's actual url though?) and a link to phpList.com?

I don't understand how someone would use this normally

In their template, what would they write for the image link? logo.png? and the upload logo png?

mariez

26-09-14 15:43

developer   ~0055172

You have to link the image to an existing file. That file could be online like: http://www.phplist.com/images/logo-gen.png
OR offline, like a local file in your machine. If the link is online you will not be able to upload the file because is already online. If the link is local you will be able to upload the file. In your last example with NAMEY_NAME.png, you put an online path where should be a local path. So the problem is that the path is wrong.
In other words: if you open your template file in your browser as a local file, and your image is broken, it will be broken in your email too, because the path is wrong. The image path must be ok in your template before uploaded, to be ok in your email. So you have to SEE the image in your template before upload it.

mariez

26-09-14 15:47

developer   ~0055173

Last edited: 26-09-14 15:50

View 2 revisions

I think the confusion is that when Michiel said "the image exist", he is saying "the image exist (IN THE SERVER)". But in all cases the image must exist in the universe. :)

michiel

26-09-14 16:11

manager   ~0055174


yes, mariela is right.

Also on 0017419:0055171 do you see the image or not in the message you receive? Presumably you do. It does not have a URL. It's in the message. That's the whole point of uploading images to the template, they get included in the message (and therefore show even if images are blocked or the internet is down).

gingerling

26-09-14 16:42

manager   ~0055175

oh, yeah, sorry I am not explaining this very well (again). I understand most of what you have said already - my confusion is about the process that someone would go though using this tool and the choices they make, in a literal click click sense and also in a broader, documentation-and-understanding way.

My understanding of the way the tool worked initially was this:

1) designer includes a local OR remote image in your template
2) when setting up template phpList gives you the chance to upload the image because it is (as you say) useful to have the image actually included in the mail

but actually it seems to be working thus

1) designer probably does not know that they can include use local image link and upload later (can fix with documentation) (or perhaps this is "common knowledge?")
2) they upload template with link to a remote image
3) phpList says they can upload this list of images, but list is empty (cause images are remote)
4) if they NOW understand that they can upload image, they must go back and change the url and then click through again to upload.

Maybe it would be better if this screen only comes up when there is something to upload? Or if it could even allow the remote image to be saved too, that would be brilliant... As it stands, the user actually has to click "Save images" even when everything is hosted remotely and there are no images to save. That I think is the source of my confusion. It seems like it is broken, but it's not :)

michiel

29-09-14 18:05

developer   ~0055183


ok, yes, I guess we can make it less confusing by not making the "upload images" appear if there are no images to upload.

gingerling

29-09-14 18:09

manager   ~0055184

great. what do you think about the idea of phpList being able to rip the image from the link as an option tho?

gingerling

02-10-14 14:35

manager   ~0055244

mariez, I have that non-displaying issue again, I just see the alt-text

the code for logo is this

<td align="left" valign="middle" style="padding:10px;vertical-align:middle"><a style="color:#FFF;font-size:24px;font-family:Arial,Helvetica,sans-serif;font-weight:bold" title="phpList" href="http://www.phplist.com/"><img alt="phplist.com" style="border: 0px;" src="http://www.phplist.com/images/logo-gen.png" /></a></td>

the logo image does not display when I view the template in my browser

Or when I put the file on my server and use it like a normal page (I know this works fine usual)

I tried changing the link a little, no joy (there was originally an extra / between .com and images)

gingerling

02-10-14 14:36

manager   ~0055245

oh wait, it was my tracker blocker

the privacy badger blocked this

interesting...

gingerling

02-10-14 14:39

manager   ~0055246

I tweeted my contact at privacy badger about it will keep updated

mariez

02-10-14 17:10

developer   ~0055249

Is is resolved? if it is not maybe is an html problem. You can try adding width and height to the img tag. so the code will look like this:

<td align="left" valign="middle" style="padding:10px;vertical-align:middle"><a style="color:#FFF;font-size:24px;font-family:Arial,Helvetica,sans-serif;font-weight:bold" title="phpList" href="http://www.phplist.com/"><img alt="phplist.com" style="border: 0px;" src="http://www.phplist.com/images/logo-gen.png" width="243" height="55" /></a></td>

gingerling

02-10-14 17:17

manager   ~0055250

yes, it was a plugin blocking trackers... I am trying to establish why phpList logo is seen as tracker

michiel

06-10-14 21:56

developer   ~0055290


the action on this issue is to remove the page that ask for images to upload if there aren't any.

gingerling

16-10-14 16:00

manager   ~0055451

I am not sure that this really works either. I get the following


add or edit a template

Template does not contain local images


that sounds like an error especially as there is no "continue" button. Can it go straight to the templates page instead?

gingerling

16-10-14 16:01

manager  

Issue History

Date Modified Username Field Change
25-09-14 19:20 gingerling New Issue
25-09-14 19:20 gingerling Status new => assigned
25-09-14 19:20 gingerling File Added: phpList_template.html
25-09-14 19:26 michiel Note Added: 0055162
25-09-14 20:56 michiel Relationship added related to 0004221
25-09-14 21:03 michiel Note Added: 0055163
25-09-14 21:03 michiel Note Added: 0055164
26-09-14 00:28 mariez Note Added: 0055165
26-09-14 11:22 gingerling Note Added: 0055167
26-09-14 11:31 michiel Note Added: 0055168
26-09-14 13:33 gingerling Note Added: 0055171
26-09-14 15:43 mariez Note Added: 0055172
26-09-14 15:47 mariez Note Added: 0055173
26-09-14 15:50 mariez Note Edited: 0055173 View Revisions
26-09-14 16:11 michiel Note Added: 0055174
26-09-14 16:42 gingerling Note Added: 0055175
29-09-14 18:05 michiel Note Added: 0055183
29-09-14 18:05 michiel Target Version 3.0.8 => 3.0.9
29-09-14 18:05 michiel Summary Adding template chapter, bug with images => Adding template chapter, confusion with images
29-09-14 18:09 gingerling Note Added: 0055184
02-10-14 14:35 gingerling Note Added: 0055244
02-10-14 14:36 gingerling Note Added: 0055245
02-10-14 14:39 gingerling Note Added: 0055246
02-10-14 17:10 mariez Note Added: 0055249
02-10-14 17:17 gingerling Note Added: 0055250
06-10-14 21:56 michiel Note Added: 0055290
07-10-14 17:01 michiel Status assigned => resolved
07-10-14 17:01 michiel Fixed in Version => 3.0.9
07-10-14 17:01 michiel Resolution open => fixed
16-10-14 16:00 gingerling Note Added: 0055451
16-10-14 16:01 gingerling File Added: Screenshot from 2014-10-16 15:58:50.png
16-10-14 16:11 gingerling Relationship added related to 0017475