View Issue Details

IDProjectCategoryView StatusLast Update
0017363phplist applicationSubscriber Exportpublic10-10-14 12:16
Reportertynaz 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPHP 5.5 MySQL 5.5.38OSCentOS 6.5OS Version
Product Version3.0.7 
Target Version3.0.9Fixed in Version3.0.9 
Summary0017363: EXPORT subscribers does not produce csv file.
DescriptionWhile trying to export a list of about 4500 subscribers the export fails and does not produce any error or warning. The page simply refreshes.
Notes: some data was imported from export files from phplist version 1.x some was collected recently with versions 3.0.6 and 3.0.7. There were some encoding issues that were fixed manually.

Troubleshooting steps were:
1. recreate database from backup only. (no luck, still no epxport)
2. full database and file restore from backup. (no luck)
3. new installation and recreating all settings and input data.(export works with only few email entries)
4. Since the current exporting is not working the old user data was imported to user_user table through MySQL. ( export fails again after importing about 4500 fields)
5. Imported partial users about 1500. (export works and produce csv file).

Assumptions and Questions:
I assume it is either data corruption or data quantity is the cause. Possible?
This happening since the update to 3.0.7. Any known bugs or issues?

Is there a limit to how many fields can be exported?
Can any sort of data corruption affect export process? If so what could be the causes and what to look for in db table?

What else could be affecting exporting? How can get some logging or feedback from the it? PHP logs doesn't show anything.

Thank you
Steps To Reproducesimply have more than 3000 subscribers and try to export.
TagsNo tags attached.

Activities

michiel

08-09-14 20:55

manager   ~0054919


yes. I didn't manage to get that in the next release (due tomorrow), but it needs attention. I can replicate the export not exporting anything.

michiel

10-10-14 12:16

manager   ~0055390

https://github.com/michield/phplist/commit/4055d76c20ddcdfe82178b7e37d63a9e18068610

tried exporting 100 000 and works fine