View Issue Details

IDProjectCategoryView StatusLast Update
0017340phplist version roll out and QA[phplist application] Batch Processingpublic08-10-14 12:34
ReporterRiktam 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version[phplist application] 3.0.7 
Target VersionFixed in Version[phplist application] 3.0.8 
Summary0017340: Processing the Message Queue with Cron Jobs is Broken.
DescriptionBoth

//bin/usr/php /home/domain.com/lists/admin/index.php page=processqueue login=myusername password=mypassword >/dev/null
and

lynx -dump 'http://www.domain.com/lists/admin/index.php?page=processqueue&login=LIST_USER&password=PASSWORD' > /dev/null

type of methods to send the queue no longer process any mail in the queue.



Steps To Reproducecall
//bin/usr/php /home/domain.com/lists/admin/index.php page=processqueue login=myusername password=mypassword >/dev/null
or
lynx -dump 'http://www.domain.com/lists/admin/index.php?page=processqueue&login=LIST_USER&password=PASSWORD' > /dev/null

and the queue does not get processed.
Additional InformationThe above methods still work for -processbounces

Either all the documentation is wrong or the most important automated process of phplists is broken.

When we install phplist through cpanel it creates a cron job entry using the first described method. My hunch is that all the 3.0.7 installations in cpanel don't process queues anymore.
TagsNo tags attached.

Activities

Riktam

01-09-14 14:53

reporter   ~0054760

When i said cpanel i meant cpanel /softaculous

nymisoa

02-09-14 14:23

reporter   ~0054820

Seems to be the same issues as 0017316

https://mantis.phplist.com/view.php?id=17316

Riktam

02-09-14 16:10

reporter   ~0054828

Part of the issue is related to 0017316.
But before you hit that 0017316 problem, you have to make a call that is not what is in the documentation. If you check the URLs or the parameter on the php script call you can see that they are not the ones that are on the documentation.

Issue History

Date Modified Username Field Change
01-09-14 14:51 Riktam New Issue
01-09-14 14:53 Riktam Note Added: 0054760
02-09-14 14:23 nymisoa Note Added: 0054820
02-09-14 16:10 Riktam Note Added: 0054828
08-10-14 12:34 michiel Status new => resolved
08-10-14 12:34 michiel Fixed in Version => 3.0.8
08-10-14 12:34 michiel Resolution open => fixed