View Issue Details

IDProjectCategoryView StatusLast Update
0017328phplist applicationInterface - Administratorpublic08-10-14 13:29
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.7 
Target Version3.0.9Fixed in Version3.0.9 
Summary0017328: List category that includes single-quote does not work
DescriptionReported in the user forums http://forums.phplist.com/viewtopic.php?f=35&t=41541

If a list category is added that contains a single-quote character then on the "Subscriber Lists" page that category cannot be selected from the accordion control.

The cause is that input fields have a backslash added automatically, and that messes-up the processing. Need to use stripslashes() on input fields and also sql_escape on queries where the category is used.
Steps To ReproduceAdd a list category such as "cat's" and assign that category to a list. Then go to the Subscriber Lists page and try to select that value from the control.
TagsNo tags attached.

Activities

michiel

08-10-14 13:29

manager   ~0055338

I wonder if this applies to more characters, but for now I have disallowed single quotes in categories.

Btw "cat's" is not grammatical.