View Issue Details

IDProjectCategoryView StatusLast Update
0017315phpList 3 applicationUser Managementpublic28-05-18 09:22
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.9 
Summary0017315: make it harder to add a subscriber without them going onto at least one list, or create an "all subscribers" list
DescriptionSo we have had a few users who use phpList in a simple way, for example a small hiking club who send out their monthly schedule their hikes, who have put a subscriber on the system without putting them on a list.

This situation has cropped up a few times in different guises, some of which are complex, but I thought a good first step to making phpList easier for these people is to either make it (almost) mandatory to chose a list when adding subscribers or to automatically make a list which includes all subscribers.

TagsSubscriber Management and data accessibility, UI Improvements

Relationships

related to 0017517 resolvedmichiel export all subscribers? (now "all subscribers" list especially) 

Activities

gingerling

05-11-14 13:20

manager   ~0055588

seems to be causing a lot of confusion. Wondering if we can clarify visually what this item is. It is not actually a list, but it is under the heading lists. Perhaps we can put it in a new section? See screenshot as is and idea for change

gingerling

05-11-14 13:20

manager  

gingerling

05-11-14 13:20

manager  

samtuke

28-05-18 08:49

administrator   ~0060646

Since 3.0.9 a config option has existed to show a list of 'all subscribers'. See https://resources.phplist.com/system/config/show_list_ofall_subscribers. This is currently disabled by default however. For usability it may be better to enable it by default.

michiel

28-05-18 08:55

manager   ~0060647

The only issue is that the "all subscribers" list cannot be targetted as a list in a campaign. That is because it's not actually a list. For this to work, we should enforce a real list that always contains all subscribers.

samtuke

28-05-18 09:22

administrator   ~0060648

@michiel The 'all subscribers' list has different buttons than other lists; e.g. a link to the generic import subscribers page and a 'send a campaign to all lists' button. The difference between this meta list and the other 'real' lists could still be clearer. But the fastest way to resolve this issue seems to be to simply change the default use of this config option.