View Issue Details

IDProjectCategoryView StatusLast Update
0017288phplist applicationUser Managementpublic07-07-15 10:20
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Versionnext patchFixed in Version3.2.0 
Summary0017288: Campaign is sent to subscriber who is shown as blacklisted
DescriptionA problem reported in the forum concerning sending a campaign to a subscriber who is shown as blacklisted http://forums.phplist.com/viewtopic.php?f=35&t=41424

The sequence is a bit complicated but the problem seems to be that once an email address is added to the user_blacklist table, then it is not removed if the subscriber is deleted and then imported again as confirmed.

So the Subscriber page shows him as blacklisted because of the user_blacklist row, but that does not stop campaigns being sent to him.
TagsNo tags attached.

Activities

michiel

02-08-14 00:07

manager   ~0054464

ah, interesting. I wouldn't want to check the blacklist on every send, but I guess it would need to be done on an import.

Seems like a rather uncommon situation though.

michiel

07-07-15 09:39

manager   ~0056340

Yes, I was able to replicate this.