View Issue Details

IDProjectCategoryView StatusLast Update
0017284phplist applicationAll Otherpublic17-05-15 15:48
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.1.XFixed in Version3.0.8 
Summary0017284: activate spell check in fckeditor (or troubleshoot lack of spellcheck if it is activated allready)
Descriptionas discussed, the spell check in the fckeditor seems to be switched off. This should be on in my view :)
TagsUI Improvements

Activities

michiel

30-07-14 10:21

manager   ~0054444


it's highly untested and needs someone to ensure that it will work without failing. Moreover, the fckeditor is very old and needs phasing out.

You may have some luck trying to activate it with the "Second row of toolbar elements in the editor" settings.

gingerling

30-07-14 10:26

manager   ~0054445

I don't see any second row :/

when you say it's untested, do you mean in general? All this is as far as I can see is allowing the browser spell check to do its thing - it's not actually a new tool we are activating. No idea why they let it get tuned off to be honest :/

michiel

30-07-14 10:58

manager   ~0054446

second row is here:

https://www.phplist.com/?lid=512

untested for us. Are you sure it's available in our version of fckeditor?

gingerling

30-07-14 11:27

manager   ~0054448

I don't know - but as I say, this isn't a button or additional function or anything, it is just literally allowing the browser level spell check to work within the window. I assume they block it because they have their own spell check, but currently we have neither.

personally I think spell check is pretty vital

gingerling

30-07-14 11:31

manager   ~0054449

I can't see enough details to be sure that this is the issue because the editor is an iframe

gingerling

30-07-14 11:37

manager   ~0054450

here are the docs for 4

http://docs.ckeditor.com/#!/guide/dev_spellcheck-section-the-native-spell-checker

but we are on 2...

duncanc

01-08-14 13:28

developer   ~0054457

There is a configuration setting to use the browser native spell checking, see
http://docs.cksource.com/FCKeditor_2.x/Developers_Guide/Configuration/Configuration_Options/FirefoxSpellChecker

but the fckeditor plugin doesn't provide a way to add or modify the fckeditor configuration.

If you use the CKEditor plugin then you can specify a custom configuration file. Adding this line to the custom configuration file does indeed enable the browser spell checking (at least in Firefox).

config.disableNativeSpellChecker = false;

gingerling

04-08-14 10:14

manager   ~0054471

so, two options for this are

1) add this function to the fckeditor plugin?
2) use the CKEditor plugin

I think we should take a look at 1, it may be simple to code in and it's fairly standard functionaity that we should have.

I am not sure as to the situation with these two plugins. Is one prefrable? Is one newer? I think hosted ises fckeditor?

michiel

02-09-14 12:34

manager   ~0054818

https://github.com/michield/phplist-plugin-fckeditor/commit/a6b4004e809f7221f433ba415da4e6251ca17d89

Now the biggest problem is to make sure the correct version is included :-)