View Issue Details

IDProjectCategoryView StatusLast Update
0017282phplist applicationAll Otherpublic22-08-14 07:45
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.XFixed in Version3.0.8 
Summary0017282: Plain text generate from html button makes text but does not show it in the box
DescriptionI am not sure if this is a bug or not - when I press the "Generate from html" button to create a plain text version, nothing seems to happen. I sent a test email and indeed the plain text version was fine, but no text displays in the "Plain text version of message" box so the only way to check the auto-generated text is to send a test. Is this correct?

If so, we should find some way to show that the generation is complete, but the best thing would be for the text to actually appear in the box.
TagsNo tags attached.

Activities

michiel

29-07-14 08:43

manager   ~0054428

yes, that's when there is a lot of text that it fails.

Haven't managed to avoid that yet. It is explained in the help text.

gingerling

29-07-14 10:37

manager   ~0054430

Yeah, I saw that, but this message is only 176 words, less than 1000 characters including spaces. Didn't think it constituted a "lot of test" to be honest :/

gingerling

29-07-14 10:37

manager   ~0054431

I suppose I am quite wordy.... talkative one could even say... ;)

michiel

29-07-14 10:57

manager   ~0054432

hmm, 176 words is not much. Maybe it's the text itself? Too controversial :-)

gingerling

29-07-14 11:25

manager   ~0054434

I only mention Anarchist pet food like one time! :O :)

michiel

30-07-14 11:49

manager  

text (1,280 bytes)
<p><img width="200" vspace="5" hspace="5" height="200" align="right"
src="http://www.ethical-pets.co.uk/58-652-thickbox/yarrah-organic-dry-cat-food-fish-3kg-reduced.jpg"
alt="image of a bag of Yarrah cat food" />Dear Cats (and your associated
human servants)</p>
<p><em>Good news! </em></p>
<p>Some silly human types at Ethical Pets have accidentally over-stocked
Yarrah Organic and MSC certified dry cat food (the one with fish in it).</p>
<p>They have lots of 3kg bags of this delicacy that are getting near
their &ldquo;best before date.&rdquo;   The date, which is the 20th of
August, is the last day that the Yarrah Chefs guaranteed that the
vitamin and mineral contents are at the levels stated on the packaging
&ndash; so the food should still taste good for a while yet.</p>
<p>So dear felines, Ethical Pets are hoping some of your humans would
like to &ldquo;bag a bargain&rdquo; and get some of these these bags for
you. They will be 50% off, which is quite cheap for such a lovely
ethical food.</p>
<p><em>They are now priced at &pound;11 for a 3kg bag.  </em></p>
<p>If you make your cat-eyes big and round and cute, they might click
here and get you some! Yummy   `</p>
<p>Lots of Love and fuss</p>
<p>Anna &amp; Joey</p>
<p>The Ethical Pets Humans</p>
<p>&nbsp;</p>
text (1,280 bytes)

gingerling

12-08-14 15:27

manager   ~0054573

Ok so it hangs at the pound sign. In html this is showing as £11 which according to http://www.ascii.cl/htmlcodes.htm is ascii correct so not sure what the issue is

gingerling

21-08-14 14:36

manager   ~0054667

I fixed this for the manual screenshots by working around the issue. It's very odd though. To summarize the text IS generated and goes out as a text email in test fine, but it does not display, it hands at £. I am assuming it's another ASCII thing, but without a keypad on my laptop it's hard to type it in using the ASCII number. Anyway, ideally, it should not hang :)

michiel

21-08-14 19:58

manager   ~0054672

the only way I managed to get it to kind of work, is to use ENT_IGNORE in the character conversion. This means some characters (like £) will be lost.

gingerling

22-08-14 07:45

manager   ~0054673

Hum, well thats not ideal :/ Do we know how come it works okay in the auto-generation but not in the display?