View Issue Details

IDProjectCategoryView StatusLast Update
0017270phplist applicationAll Otherpublic18-07-14 10:51
Reporterrata 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0017270: Default phplist installation fails to set a default directory for plugins and says it's not writable
DescriptionThe default phplist installation doesn't use public_html/lists/admin/plugins/ (relative to the phplist root installation) as the plugins directory.

That seems like a problem, but the error that is shown is misleading: it says it is not writable. And makes one waste time trying to debug it.

Setting the the PLUGIN_ROOTDIR var to the public_html/lists/admin/plugins/ dir in config.php (that is not even commented there) does the trick: removes the warning that the plugin root dir is not writable.

I think that, by default, that dir should be used as the PLUGIN_ROOTDIR. That will make the error have more sense, because if that dir is not writable, it has sense, and if the var is not defined in config.php, by default it will use that dir. The user can always change the dir by defining the var, but having a reasonable default sounds like the proper thing IMHO.
TagsNo tags attached.

Activities

michiel

18-07-14 10:51

manager   ~0054320

that was kind of on purpose, because I'd like active awareness of how plugins work.

but I've now defaulted it to "plugins" which means the default subdir of admin.