View Issue Details

IDProjectCategoryView StatusLast Update
0017240phplist applicationUser Managementpublic18-07-14 11:16
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0017240: Misleading fields on userhistory records
DescriptionWhen a subscriber re-subscribes after having unsubscribed, the records written to the userhistory table have some misleading fields.

The record written for the re-subscription is displayed on the Subscription details tag like this:

//////////////////
49 xxxxxx@gmail.com 2014-06-30 10:01:10 Re-Subscription
detail http://strontian/lists/admin/?page=user&id=1

Subscribe page: 1
autoresponder_1 =
Name = Duncan resubscribing
City = London
A text area =
htmlemail = 0
*changed* from 1

//////////////////

The url http://strontian/lists/admin/?page=user&id=1 is wrong as it seems to say that the re-subscription was through the admin interface, users page, whereas it was on the public subscribe page.

The next record written to userhistory is like this:

//////
50 xxxxxx@gmail.com 2014-06-30 10:01:54 Removed from blacklist by padmin
detail Removed from blacklist by padmin
//////

This is wrong as it seems to say that the administrator padmin removed the subscriber from the blacklist, whereas it was a result of a re-subscription.

The next record written to userhistory is like this:
//////
51 xxxxxx@?gmail.com 2014-06-30 10:01:55 Confirmation
detail Subscriber removed from do-not-send list for manual confirmation of subscription
//////

This is accurate but is repeating the previous message. It would be clearer to keep this message and remove the "Removed from blacklist by padmin" message.
TagsNo tags attached.

Activities

duncanc

30-06-14 15:30

developer   ~0054074

Last edited: 30-06-14 15:57

View 4 revisions

The URL in the first point is written by line 214 in admin/subscribelib2.php
    $history_entry = 'http://'.getConfig("website").$GLOBALS["adminpages"].'/?page=user&id='.$userid."\n\n";

Note that Mantis seems to convert the & amp ; into an &.

Is the idea to provide a link to the subscriber page? That doesn't work because the & in the URL gets replaced by & amp ;.

duncanc

30-06-14 15:41

developer   ~0054075

Last edited: 30-06-14 15:54

View 2 revisions

The second message "Removed from blacklist by padmin" includes the admin id because the confirm link in the confirmation request email opened in browser where I was already logged-in as padmin.

Without that, the message is simply "Removed from blacklist" which is fine although is duplicated by the following message.

michiel

10-07-14 20:32

manager   ~0054220

Yes, and as found in 0017240:0054074 I only added the link to the "user page" for convenience. Not to record the URL at which it happened.

And the done by admin was added because you were logged in as admin as well. That won't happen usually.

So, is there still something to do on this? Maybe make it clearer that the URL is to view the subscriber?

duncanc

11-07-14 08:31

reporter   ~0054226

At present the URL is malformed, as it is displayed with & amp ; instead of & (hopefully Mantis will not change that), and, as it is not actually a link that can be be clicked, I suggest removing it.

The admin is already viewing the details of that subscriber so it is not really adding anything. It is the same URL as the "Details" button on that page.

The second and third messages in effect are duplicated, but the third is more explicit. If the second one could be removed then there would be less clutter.
Also one message refers to blacklist, the other to do-not-send. Are these the same thing and should there be consistent wording?

michiel

18-07-14 11:16

developer   ~0054322

yes, blacklist and do-not-send list are the same. The terminology will need updating in the translation system. I prefer do-not-send list, as it's clear what it does and has not racial problems. It's a bit historical to still have blacklist in places.

Even though the two lines are similar, the one about the admin is only there because you're admin as well as subscriber. It won't be there otherwise.

Issue History

Date Modified Username Field Change
30-06-14 09:46 duncanc New Issue
30-06-14 09:49 duncanc Description Updated View Revisions
30-06-14 15:30 duncanc Note Added: 0054074
30-06-14 15:41 duncanc Note Added: 0054075
30-06-14 15:54 duncanc Note Edited: 0054075 View Revisions
30-06-14 15:55 duncanc Note Edited: 0054074 View Revisions
30-06-14 15:56 duncanc Note Edited: 0054074 View Revisions
30-06-14 15:57 duncanc Note Edited: 0054074 View Revisions
10-07-14 20:32 michiel Note Added: 0054220
11-07-14 08:31 duncanc Note Added: 0054226
15-07-14 09:15 michiel Target Version => 3.0.7
18-07-14 11:16 michiel Note Added: 0054322
18-07-14 11:16 michiel Status new => resolved
18-07-14 11:16 michiel Fixed in Version => 3.0.7
18-07-14 11:16 michiel Resolution open => fixed