View Issue Details

IDProjectCategoryView StatusLast Update
0017207phpList 3 applicationInstallationpublic21-06-18 14:00
Reporterrata Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0017207: Installation doesn't say to have a "DirectoryIndex index.php index.html"
DescriptionThere is no step on the installation steps (http://docs.phplist.com/PhplistInstallation.html) that something like:

    DirectoryIndex index.php index.html

is needed. Between step 5 and 6 of the "Short instructions" should be added. Because to go to the URL asked on step 6, that is needed.

Right now, when doing step 6 a very clear error is thrown saying that something like "DirectoryIndex index.php index.html" should be added. And that will happen to all Debian-based distros at least, so adding a statement saying something like the error does will be more correct to (at least) debian based users.
Tagsdocumentation

Relationships

related to 0017208 resolvedgingerling Give an example for (at least) debian based distros ? 

Activities

duncanc

08-06-14 09:58

updater   ~0053882

The .htaccess file in the lists directory already has that:

DirectoryIndex index.php

michiel

08-06-14 10:57

administrator   ~0053884

Yes, so the central server settings need to be set so that the .htaccess is interpreted. I'm not sure that is the case with a standard debian installation

At least AllowOverride Indexes

http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

rata

09-06-14 16:46

updater   ~0053891

Ohh, I didn't realize the tarball has .htaccess files

"AllowOverride All" seems better IMHO. As AllowOverride Indexes is not enough now (it gives an error, because it seems we are using more directives that the allowed for Indexes) and makes it safe for the future to be free to use the directives we need.

I've done that on the #17208

I can close this now, right ? :)

michiel

10-06-14 10:10

administrator   ~0053895


It may be useful to add a note somewhere in the docs about this, just in case.

support

17-06-14 13:41

administrator   ~0053955

noted

gingerling

01-09-14 18:23

manager   ~0054780

passed over to the writer of that chapter