View Issue Details

IDProjectCategoryView StatusLast Update
0017193phplist applicationBatch Processingpublic16-07-14 16:44
Reporterspryte 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0017193: Sending Domain Batch Size + 1 emails
DescriptionIt was recognised over a year ago (see https://mantis.phplist.com/view.php?id=16742) that DOMAIN_BATCH_SIZE + 1 emails are sent per domain in each DOMAIN_BATCH_PERIOD.

At the time it was accepted that domain throttling needed a complete review which is considered a task for the future.

However since the fix is a simple one applying this now would, in the meantime, make the application behave as intended.
Steps To ReproduceSet DOMAIN_BATCH_SIZE = 1 (or more) and send consecutive emails to a domain.
Additional InformationThe fix requires a one line change which in the current version 3.0.6 requires
line 994 of file admin/actions/processqueue.php to be changed from

                    $domainthrottle[$domainname]['sent'] = 0;
to
                    $domainthrottle[$domainname]['sent'] = 1;

to reflect that one email has just been sent when this line is executed.
TagsNo tags attached.

Activities

There are no notes attached to this issue.