View Issue Details

IDProjectCategoryView StatusLast Update
0017176phpList 3 applicationMessage Send Processpublic06-10-15 14:07
Reporterdanwaterloo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformintelOScentosOS Version5.5
Product Version3.0.5 
Target Versionnext patchFixed in Version 
Summary0017176: when 'send a web page' contains spanish language characters, improperly encoded
DescriptionWhen sending a web page contains 'foreign' characters, (oomlat, tilde, etc.), the page is not properly encoded to send. The foreign characters are garbled. (on this same system, when posting spanish language text into to the 'message editor' box, everything is translated properly.)
Steps To Reproducesend a web page, using this page:
http://www.newsletter.illinois.mx3a.com/vo/socsci_Ies15a.html
send a test... notice that the characters are all garbled.
TagsNo tags attached.

Activities

michiel

03-05-14 23:10

manager   ~0053652

interesting. My first thought was a mixup of character sets, but the page is in UTF-8 so that should work.

Needs checking and fixing.

danwaterloo

03-05-14 23:20

developer   ~0053653

things that come to mind are:
1. my php settings (php.ini) aren't set right...
2. the line that reads the page and creates the cached version doesn't use the correct charactersets.
3. my o/s somehow reads the page into an incorrect character set, and then it can't be fixed...
since it works when the same text is pasted into the message editor box, the issue appears to be in the 'send a web page' function...

danwaterloo

06-05-14 02:58

developer   ~0053654

Duncan posted this on the forums...
--------
The function fetchUrlCurl() in file admin/lib.php seems to be responsible for fetching remote pages, if your php has curl installed. That function doesn't do encoding conversion, but see the following function fetchUrlPear() that does do conversion.

You could try adding similar code to fetchUrlCurl() to convert to utf-8.
--------

michiel

16-07-14 15:24

manager   ~0054287

Trying to replicate, I find the following:

1. both the curl and PEAR versions fetch the page fine.
2. the HTML versions have all the correct characters
3. the Text version has most of the accented characters correct, except the

 ?Esperamos recibir pronto su propuesta y contar con su participación en Split!

which should be

¡Esperamos recibir pronto su propuesta y contar con su participación en Split!

This is the same for both the Curl and Pear fetching.

So, it looks like the problem is with the HTML to text conversion.

michiel

16-07-14 15:26

manager   ~0054288


this needs more data to replicate. Do you get more characters wrong than the one that I have? In that case, my method to replicate the problem is incorrect.

danwaterloo

06-10-15 13:37

developer   ~0056967

I have updated the perl to 5.8.8, (on centos 5.6), and changed the default encoding on my client email reader (thunderbird) to UNICODE(UTF-8) and everything seems to be displaying as it should.

At this point, please close this request. Thanks!

michiel

06-10-15 14:07

manager   ~0056971

great, thanks for checking