View Issue Details

IDProjectCategoryView StatusLast Update
0017171phplist applicationInterface - Administratorpublic17-07-14 22:02
Reporterlorenzo974 
PrioritynormalSeverityblockReproducibilityunable to reproduce
Status resolvedResolutionfixed 
PlatformchromeOSwindowsOS Version8
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0017171: Sent Campaigns view broken (not displaying list or elements)
DescriptionAfter upgrading from v.2.10.19 to v.3.0.6 I have found that you can not see the list of old messages sent, and the page appears to be broken and not complete (screens can be seen in the forum at this link: http://forums.phplist.com/viewtopic.php?f=35&t=39881&p=101039#p101039)

I followed the instructions from Duncan and I climbed to the cause: line 216 of /admin/lib.php, for now I solved with this change to the code:

from:
unset ($ messageData ['excludelist'] ['unselect']);
to:
$ messageData ['excludelist'] ['unselect'] = NULL;

but I'm not sure is fine 100%
and also I have seen that there are other similar statements that could cause the same problem.
TagsNo tags attached.

Activities

lorenzo974

28-04-14 14:12

reporter   ~0053626

I forgot to mention the PHP error encountered, it is the following:

fatal error: can not unset string offsets

michiel

17-07-14 22:02

manager   ~0054315

the proposed solution actually causes complications. So, I've sorted it out differently. Once 3.0.7 is out, it will be good to check that worked.