View Issue Details

IDProjectCategoryView StatusLast Update
0017112phplist applicationUser Managementpublic23-07-14 18:20
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.5 
Target VersiondocumentationFixed in Version3.0.7 
Summary0017112: Problems deleting subscribers for an ordinary admin
DescriptionA problem with deleting subscribers and requeuing messages was reported on the support forum - http://forums.phplist.com/viewtopic.php?f=17&t=40693

The problems apply to an ordinary admin and seem to confirm that the permissions model isn't working.
TagsNo tags attached.

Activities

michiel

14-03-14 14:04

manager   ~0053344


I never intended normal admins to be able to delete subscribers. There's no need for this when subscribers can be excluded from mailings, which is what you mostly want, and keeping them in the system allows for an audit trail.

duncanc

14-03-14 14:37

developer   ~0053348

So an ordinary admin can add subscribers, but not delete them? If that is the case
 then the Delete button shouldn't be displayed for an ordinary admin.

What currently happens is that he appears to be able to delete the subscriber but the subscriber is only removed from any lists and is then not listed when the admin view subscribers.

I'm not sure this is the functionality that people expect when creating an ordinary admin. It will force them to create super admins, which will give those admins more powers than necessary.

michiel

23-07-14 16:42

manager   ~0054382

The subscriber page says clearly "Delete will remove subscriber from the list".

The idea is that sub-admins manage their own subscribers using lists, but they take their subscribers from a shared pool. Therefore deletion cannot delete the subscriber only the list-membership.

I guess this needs to be made very clear in the docs.

gingerling

23-07-14 17:43

manager   ~0054383

Or maybe it could say

"Delete will remove subscriber from this list, but not all lists" or something?

duncanc

23-07-14 17:52

developer   ~0054384

I think that it will be clearer to either disable the delete button for an ordinary admin, or change the caption to "remove from all lists" to reflect what it actually does.

I prefer the first approach, because you can already remove the subscriber from all lists on the "Lists" tab.

michiel

23-07-14 18:20

manager   ~0054386

ok, have removed the "delete" button for non-super admins.

it's true that you can remove subscribers from the lists on the lists tab. However, with many lists, this may be tedious.

What's also interesting is, that if you remove a subscriber from all lists (as sub-admin), they disappear from your subscriber listing. You can however recover them by adding the same email address again as a new subscriber. This will bring up the original subscriber profile.