View Issue Details

IDProjectCategoryView StatusLast Update
0017086phplist applicationEmailpublic17-07-14 10:55
ReporterHvD 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.5 
Target Version3.0.7Fixed in Version3.0.7 
Summary0017086: Avoid sending as a webpage and using a template at the same time
DescriptionThese days I send mail to my clients by “sending as a webpage” with phpList.
 
This webpage is a complete html-page written in Dreamweaver.
 
However I found out after sending a test-email that phpList is adding some html to my webpage as well.
 
At the beginning <html> <body>, and at the end </html> </body>.
 
All the html and body tags are already in my page.
 
My outlook has no problem with this, but when I open the email in Dreamweaver it gets clear that this html page has html bugs.
 
After removing the tags that are provided by phpList everything is OK.
Steps To Reproduce1. Create a new message in phpList and choose the option "sending as a webpage"
2. Fil in the other stuff.
3. Send a test e-mail to your e-mail address.
TagsNo tags attached.

Relationships

related to 0017267 resolvedgingerling too easy to wipe capaign contents by clicking "send a web page" 
related to 0017188 new URL placeholders in Template not working 
related to 0017266 resolvedgingerling Avoid sending as a webpage and using a template at the same time 

Activities

HvD

05-03-14 20:03

reporter   ~0053228

Sorry. Steps to reproduce are not complete.

I also selected a template for the webpage to be shown in.

So now it's complete

michiel

06-03-14 15:58

manager   ~0053239

ah but that doesnt make sense. when using send-a-webpage it assumes the page is complete. but with a template around it that would be another wrapper.

can you try without a template?

HvD

06-03-14 19:57

reporter   ~0053246

Might be so. But this could happen to other people as well. I was used working with the editor and templates and switched to using 'sending as a webpage'. So I kept working with the templates, never thought of the idea of integrating both in my webpage to be send.
But I tested integrating my template in the website-page and after that there were no additional html or body tags.
Might be an idea to build something in the program to prevent this way of sending or put something in the tutorial or help text.
Thanks fort solving this.

michiel

07-03-14 02:56

manager   ~0053250


Yes, that may be good to add. A notice when a template is used on send-a-webpage. Or maybe even drop the template when using send-a-webpage.

gingerling

15-07-14 09:23

manager   ~0054267

I have made an email using html in the WYSIWYG and then clicked the send a page button (by accident) before now and it deletes all the stuff in the WYSIWYG - bit scary tbh!

michiel

15-07-14 09:50

manager   ~0054269

gingerling, that's a different issue. Can you open a new issue for that?