View Issue Details

IDProjectCategoryView StatusLast Update
0017056phplist applicationStatisticspublic20-02-14 01:01
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.5 
Target Version3.0.6Fixed in Version3.0.6 
Summary0017056: Clicks column on user history is always 0
DescriptionOn the History of a Subscriber page, page=userhistory&id=xxx , the Clicks column on the Campaigns tab is always 0. This is because the code is looking at the old click tracking table, see file admin/commonlib/pages/userhistory.php line 82:

      $clicksreq = Sql_Fetch_Row_Query(sprintf('select sum(clicked) as numclicks from %s where userid = %s and messageid = %s',
        $GLOBALS['tables']['linktrack'],$user['id'],$msg['messageid']));

The code should be using the linktrack_uml_click table instead.
TagsNo tags attached.

Activities

duncanc

07-02-14 10:11

developer   ~0052891

Last edited: 07-02-14 10:11

View 2 revisions

The column names in the new table are the same, so the change is simply to use the table 'linktrack_uml_click' in the query instead of 'linktrack'

michiel

08-02-14 01:58

manager   ~0052911

cool, nice find.

michiel

20-02-14 01:01

manager   ~0053092

https://github.com/michield/phplist/pull/12