View Issue Details

IDProjectCategoryView StatusLast Update
0016993phplist applicationCommand Linepublic18-07-14 18:24
Reporterjholland 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04 LTS
Product Version3.0.5 
Target Version3.0.XFixed in Version3.0.7 
Summary0016993: Commandline send does not work
DescriptionCommand line "-psend" does not work with phplist 3.x. The "-psend" feature does work with phplist 2.10.19.
Steps To Reproducephplist -psend -s This is the subject -l test 1 2 3 -f me@server.com < messagefile
Additional InformationIt seems to have problems if there is a saved draft but when I delete the saved draft and try the -psend again I get different error of "Please enter a from line." that looks as if it is intended for a web browser.
TagsNo tags attached.

Activities

michiel

27-12-13 08:54

manager   ~0052494

ah, yes, I never kept track of that. Didn't think anyone used it.

jholland

27-12-13 21:00

reporter  

phplist-3.0.5_issue_0016993_fix.zip (36,208 bytes)

jholland

27-12-13 21:03

reporter   ~0052495

Last edited: 27-12-13 21:04

View 2 revisions

Hey Michiel, I went through the debugger and compared how phplist 2.10.19 handled the psend command versus how phplist 3.0.5 handled it. After that I managed to get psend to work on phplist 3.0.5. I have attached a .zip file of the changes I made if you want to add them to the next version of phplist. Thanks! Jason

jholland

27-12-13 21:08

reporter   ~0052496

FYI, the send.php.changeset.txt in the zip file I just uploaded looks like I did a lot of changes but I only wrapped a block of code inside an if (!$GLOBALS["commandline"]) {...} statement.

michiel

27-12-13 23:28

manager   ~0052497

If you can do it as a pull request on https://github.com/michield/phplist that would be brilliant.

jholland

30-12-13 15:47

reporter   ~0052498

Hey Michiel, I just sent the pull request. Thanks!

michiel

31-12-13 10:10

manager   ~0052499

brilliant, got it, thanks. It may take a little while for me to process it, but it s in the right place :-)

michiel

31-12-13 10:10

manager   ~0052500

https://github.com/michield/phplist/pull/16

michiel

18-07-14 18:24

manager   ~0054328

merged it, tested it and it works great!