View Issue Details

IDProjectCategoryView StatusLast Update
0016943phplist applicationMessage Managementpublic18-07-14 11:42
ReporterBaliDave 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version3.0.5 
Target Version3.0.7Fixed in Version3.0.7 
Summary0016943: Need to be able to edit and delete campaigns
DescriptionIn 2.x you could edit and delete campaigns ("messages" in 2.x), but those capabilities have disappeared in 3.x. Now there's only View and Requeue.

These capabilities are needed for a variety of reasons, including:
-- test sending a campaign with Criteria to a select list and now need to send to real list
-- test sending a campaign with specialized footers/... and styled text, and now needed to resend to real list
-- being able to delete test campaigns that just clutter up the list

I've been using phplist for a LONG time and rely on all these capabilities, especially since I send to big lists and complete testing is essential. I understand how people can shoot themselves in the foot with such, but it's needed in the real world. Alternatively a Clone campaign could serve the function of edit, but we still need delete to get rid of the trash. And the Clone function would also need to clone things like Criteria, which is now a plugin (why is that? to me and others, that's a core capability)

There are a number of other people complaining about this in the forum, see e.g. http://forums.phplist.com/viewtopic.php?f=35&t=39380 and http://forums.phplist.com/viewtopic.php?f=35&t=39463 One user even has a hack to the code to add this (see http://forums.phplist.com/viewtopic.php?f=35&t=39463#p96715)

Please put these capabilities back into phplist soon -- I and many others need to move soon to 3.x for a few sites due to the php 5.3 compatibility issue.
TagsNo tags attached.

Relationships

has duplicate 0016851 resolvedmichiel Unable to delete 'sent' messages 
related to 0016916 resolvedmichiel Edit sent messages 

Activities

michiel

06-11-13 11:44

manager   ~0052399


ok, thanks for the contribution. It's good to get feedback like this. I will add a config to make the delete button appear.

In general the idea is not to duplicate campaigns, but to re-use them with new parameters when resending to different lists.

Attribute selection has become a plugin to simplify the core code, which makes maintenance easier.

BaliDave

07-11-13 02:17

reporter   ~0052400

OK, thanks, the delete button will help. But I still think an Edit and/or a Clone capability is virtually essential to many of us. Otherwise we have to rely on our memories after sending an email to some testing list to verify all is correct, including Criteria, styling, personalized footers, attachments, ... The inline "Test Send" does NOT test things like the Criteria we used, nor does it work well when you want to send to a bunch of people for testing purposes. Sending to test lists on the other hand allows us to verify that all is working as wanted, including recipients selected, so now we want to send to the real list, or perhaps fix the campaign and test again.

Personally I'd prefer BOTH edit and clone capabilities: edit for the case above, and clone for when you're wanting to send a similar message with many parts the same. But at least one is needed.

To rely on our memories, and our errant fingers, to recreate the SAME message in all it's facets, to send out to our real list, is bound to lead to problems. Sending a message to a test list is an appropriate, and sometimes essential, means for testing. Thus the need for an edit/clone campaign.

So I urge PHPList developers to include this capability.

julienl

07-11-13 08:28

reporter   ~0052401

Same as BaliDave : it "must" be an edit & clone button for sent campaign. The edit button helps me a lot on version 2 !

michiel

07-11-13 12:34

manager   ~0052403

So, what's wrong with the following workflow:

1. create a campaign, set everything up and select the "test list" for sending.
2. once the test comes out fine, go back in and re-edit the campaign, adding the real list
3. re-queue the campaign and it is sent out to the real list.

that way, there's no need for deletion, or cloning and there is less danger of

1. making errors when creating the new campaign (as you are actually resending the one in the test)
2. duplicating content to subscribers

Maybe the problem is that once you sent one test, it will not send anything to the members of the test list? In that case, a solution would be to eg allow this to happen.

Just trying to think out of the box.

julienl

07-11-13 12:58

reporter   ~0052405

For the first part : how can I re-edit the campaign ? I've only resend and view.

For the second part : I want to create a "new" campaign with modifications of an "old" campaign. Now, I make my modifications in BBEdit and copy / paste to phplist to a new message. This step can be avoided with a "clone" or maybe "copy as a new campaign".

michiel

07-11-13 13:05

manager   ~0052409

When you "view" a campaign, there is the option to resend it to a list that is has not been sent to at the bottom. I guess this needs to become more obvious?

Yes, I can see the attractiveness of cloning and re-editing to change a little bit of the campaign. The main reason I try to avoid this is for phpList not to get the blame when people doing that accidentally send the same content to their subscribers. This has happened in the past.

BaliDave

07-11-13 13:23

reporter   ~0052411

Michiel, OK, I see that option now to resend to a different list -- I did miss that before. But what if I need to make changes to the email after I send it to the test list (i.e. I want to send it to the same test list, but change it first)?

If clone is to be the solution, can we be assured that the Criteria will also be cloned?

bk268

25-05-14 18:52

reporter   ~0053814

Please return the EDIT button for Active messages that are under embargo, so I can still edit the message before it is sent for real.

My message is rescheduled every week, and the only changing part is included by an URL placeholder. Sometimes I want to change small things to this weekly rescheduled message, but this is impossible now because the EDIT button has gone.

michiel

17-07-14 15:30

manager   ~0054303

You can click "Pause" on an active message and then the edit button will re-appear.

michiel

18-07-14 09:29

manager   ~0054318

I've added the option to mark a campaign as "test-campaign" which then provides the option to delete the campaign from the lists of active or finished campaigns.