View Issue Details

IDProjectCategoryView StatusLast Update
0016888phplist applicationConfigurationpublic29-11-15 14:42
Reporterlwc 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.0.3 
Target Versionnext minorFixed in Version3.2.4 
Summary0016888: Aliases (interchangeable) domains for Domain Throttle
DescriptionSome ISPs have aliases domains. If, say, @something.net and @something.net.il can be used interchangeably, it hurts Domain Throttle's impact. Some ISPs have way more than 2 interchangeable domains, for example if they bought smaller ISPs and didn't want to force old users to tweak their addresses.

I propose a config setting to define interchangeable domains, for example:
$interchangeable domains_throttle = array(
  array("something.net", "something.net.il"),
  array("another_example.net", "another_example.com")
);

That is, unless you think such domains only seem interchangeable, but actually have separate spam systems?
TagsConfiguration and sending

Activities

michiel

25-09-13 16:37

manager   ~0052288

yes, that's an interesting idea. But the options are unlimited.

It might be good to make this a community effort, to build up the mapping of domainX, domainY, .... , => domainA

lwc

26-09-13 15:17

reporter   ~0052291

First introduce a local option so we could do it ourselves. Country based lists would benefit from it because some countries only have very few ISPs.

Only then take the time to make an online database for it with the config option to use it in addition to the local option. Alternatively, simply make a wiki page that could be copied and pasted into configs (or copy it yourself into any new version's default config).

michiel

29-11-15 14:36

manager   ~0057359

https://github.com/michield/phplist-plugin-domainthrottlemap

michiel

29-11-15 14:42

manager   ~0057360

https://resources.phplist.com/plugin/domainthrottlemap