View Issue Details

IDProjectCategoryView StatusLast Update
0016871phpList 3 applicationPlugin APIpublic08-07-15 08:53
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.0.3 
Target Versionnext minorFixed in Version 
Summary0016871: Plugin method processSuccesFailure() doesn't appear to have any effect
DescriptionThe plugin method processSuccesFailure() doesn't appear to have any effect.
The comment block in defaultplugin.php seems to suggest that the plugin can decide to fail the message, but the calling code ignores what the plugin returns.

    # purpose: process the success or failure of sending an email in $sendformat
    # if function returns false, caller will know the whole email should be marked as failed
    # Currently used in sendemaillib.php


It is called in sendemaillib.php before the email has been sent.

The method name is also misspelt - it should be processSuccessFailure(), but would be better renamed to reflect what it is meant to do.
TagsNo tags attached.

Relationships

duplicate of 0015494 resolvedmichiel processSuccesFailure is not checked ok on sendemaillib when dealing with plugins 

Activities

michiel

09-09-13 12:19

manager   ~0052258

I didn't make this method and I don't actually know it's purpose. I think it was the RSS plugin, but I will need to check it. I will verify and if necessary remove the method.

I recently added processSendSuccess and processSendFailed, which have more use.