View Issue Details

IDProjectCategoryView StatusLast Update
0016866phpList 3 applicationDocumentationpublic13-02-19 12:26
Reporterwebmaste 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindows 7OSOS Version
Product Version3.0.2 
Target VersionFixed in Version 
Summary0016866: Subscribe page error
Description1. On the 3.0.2 subscribe page at the top I get:

Database error 1146 while doing query Table 'g28corn_phpl905.phplist_subscribepage' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_subscribepage_data' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_user_attribute' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_list' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_subscribepage_data' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_user_attribute' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_list' doesn't exist
Database error 1146 while doing query Table 'g28corn_phpl905.phplist_list' doesn't exist

2. I can't get the subscribe page to accept a list to subscribe to.
Steps To ReproduceEvery time I look at the subscribe page in this version
Additional InformationI just upgraded from 2.10.19. This error makes the lists system unuseable. I have to reload the old version. I use it on 3 web sites.
TagsNo tags attached.

Activities

webmaste

04-09-13 14:55

reporter  

error 3.0.2.jpg (78,992 bytes)
error 3.0.2.jpg (78,992 bytes)

michiel

04-09-13 16:37

manager   ~0052250


can you verify your table_prefix setting?

sounds like there is a mixup in the table prefix.

webmaste

04-09-13 21:12

reporter   ~0052251

The config file says
"
# what is the name of the database we are using
$database_name = "g28corn_phpl905";"
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
The prefix in config says this:
"
# if you want a prefix to all your tables, specify it here,
$table_prefix = "pl_";

# if you want to use a different prefix to user tables, specify it here.
# read README.usertables for more information
$usertable_prefix = "pl_user_";

# if you change the path to the PHPlist system, make the change here as well
# path should be relative to the root directory of your webserver (document root)

# you cannot actually change the "admin", but you can change the "lists"
# DO NOT include the file eg "index.php" because that is added when required. If you do
# it is likely to break the tracking, see http://mantis.phplist.com/view.php?id=15542
$pageroot = '/phplist';
$adminpages = '/phplist/admin';

/*"

*************************************************
The error says
"Database error 1146 while doing query Table 'g28corn_phpl905.phplist_list' doesn't exist"
**************************************************

So do I need to change something here? I just upgraded as I have done for a few years, but this time on 3 web sites I now have a corrupted system.

webmaste

04-09-13 23:22

reporter   ~0052252

I have now managed to solve the problem thank you.