View Issue Details

IDProjectCategoryView StatusLast Update
0016834phplist applicationSubscribe Processpublic01-09-13 19:14
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.0.XFixed in Version3.0.4 
Summary0016834: Problem with choosing list and subscription form
DescriptionTwo seemingly related issues to do with choosing lists for a subscribe page have been reported in the support forum:
1)
http://forums.phplist.com/viewtopic.php?f=17&t=39373

Hello I think I found a bug in 3.0.0 regarding lists being "public". On the Subscriber Lists page, if a list is used in a subscribe page, the Public column is checked but disabled so you can't make it non-public if it's in use. However, if you hit "Save Changes" on the form, the disabled checkbox is not submitted so the page updates to set the list non-public. It is not checked but still disabled, and the list is no longer available when editing the Subscribe Page. I can only get it back by editing the Subscribe Page, saving it with no changes, going back to the List page, checking the public box again, going back to the Subscribe Page and adding the List back to the Page.

I think this is because /admin/list.php, lines 15-24 update the active field along with the listorder field based on $_POST['active'][$key] regardless of whether the active field is set or not, so anytime the form is submitted while the field is disabled, if the browser does not submit the disabled value, the list will be updated to not be public.

Edit: Browser used was Chrome 28.0.1500.95, but I believe all major browsers do not submit disabled fields on form post.

2)
http://forums.phplist.com/viewtopic.php?f=24&t=39374

I only have one List and it keeps asking to select it on the subscribe form even though I have it set to ignore it if the only list available. Im using 3.0 any suggestions to remedy this? Its an upgrade from 2.1, and this is the only issue.
TagsNo tags attached.

Activities

support

16-08-13 12:15

administrator   ~0052198

ah, yes, we better get that sorted.

support

16-08-13 13:26

administrator   ~0052199

to fix it, change line 55 in editlist.php to be

  if (!isset($_POST["active"])) $_POST["active"] = listUsedInSubscribePage($id);

after that, you may need to re-save the list in order to get the active status back.

michiel

26-08-13 17:23

manager   ~0052215

you re-opened and then deleted your note. does that mean it's resolved?

duncanc

26-08-13 18:12

developer   ~0052216

Last edited: 26-08-13 18:15

View 2 revisions

There still seems to be a problem on the lists page reported by the original poster http://forums.phplist.com/viewtopic.php?f=17&t=39373#p96581

Seems to apply to a list that is used by a subscription page.
On the subscriber lists page the public checkbox is displayed as checked but disabled.

Then, on clicking the Save button, the page is redisplayed with the checkbox unchecked. Then editing the list, the public checkbox is disabled but not checked.