View Issue Details

IDProjectCategoryView StatusLast Update
0016832phpList 3 applicationInternationalization (l18n)public13-02-19 12:38
Reportermspangenberg 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionsuspended 
Product Version2.11.10 
Target Version3.0.3Fixed in Version 
Summary0016832: Localisation failed due to missing folder in Include
Descriptionin the file "lists/index.php" the including of another language besides english fails, because the url for the include is missing the folder "texts". Because of that, the language file is searched for in "lists" and cannot be found.

The lines 49-49:

if (is_file($_SERVER['DOCUMENT_ROOT'].'/'.$GLOBALS["language_module"])) {
  include_once $_SERVER['DOCUMENT_ROOT'].'/'.$GLOBALS["language_module"];
}

should be changed to:

if (is_file($_SERVER['DOCUMENT_ROOT'].'/texts/'.$GLOBALS["language_module"])) {
  include_once $_SERVER['DOCUMENT_ROOT'].'/texts/'.$GLOBALS["language_module"];
}
TagsNo tags attached.

Activities

michiel

27-08-13 18:37

manager   ~0052223

no, the inclusion of the language file in "lists/texts" is in the lines above.

this is an (undocumented) feature allowing a language file in the server root, which is different from the ones included in phpList itself.