View Issue Details

IDProjectCategoryView StatusLast Update
0016821phplist applicationConfigurationpublic02-07-13 16:29
ReporterHenk van Dijk 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.10 
Target VersionFixed in Version2.11.11 
Summary0016821: Webmaster e-mail in settings page not editable
DescriptionPerson in charge of this system in settingspage is not editable. Tried this in my own and the phplist dev system. Same result.
Steps To ReproduceAfter editing the e-mail with "info" and saving the change made the e-mail address is still webmaster@domain.
TagsNo tags attached.

Activities

michiel

01-07-13 13:07

manager   ~0052166


this field, before saving with do a validation that the value entered is an email address. It uses the phpList validation, which also includes making sure it is deliverable.

If it fails validation, it won't overwrite the existing value.

Can that be the cause of it?

Henk van Dijk

01-07-13 18:44

reporter   ~0052167

OK Michiel,

checked all the other editable e-mail addresses in the config page and they reacted the same. The reaction in the program is "settings saved" but in fact no settings were saved. That's not correct. The log didn't mention anything about the setting changed or that the e-mail address could not be verified. As I user I would like to get a message about what is going on and what I can do to get the e-mail address get verified. In fact the default e-mail address (webmaster@DOMAIN) is not existing on my host (where the phpList installation is on), the e-mail address entered is existing. Can I test something for you to make it work?

michiel

01-07-13 22:42

manager   ~0052168

ok. I guess I need to take the email verification out, or at least give a warning when it cannot be verified. Can you tell more about your setup? Are you 24hr online?

Henk van Dijk

02-07-13 05:10

reporter   ~0052169

Hello Michiel, do not know what you mean with 'setup'. My website is hosted by Antagonist. There is the dev version of phpList as well. And they are 24h online. Is that what you're asking?

michiel

02-07-13 14:58

manager   ~0052170

I've made it return an error. Can you do an update and try again?

Henk van Dijk

02-07-13 15:31

reporter   ~0052171

Yes Michiel I would like so, but what do you mean by update? Where can I get an update?

michiel

02-07-13 15:42

manager   ~0052172

ah, that will only work if you run from the latest SVN or GIT and you can do a "svn up" or "git pull"

If not, we'll have to wait until the next release

Henk van Dijk

02-07-13 15:50

reporter   ~0052173

OK Michiel, I'll check it the next release. Thanks.

michiel

02-07-13 16:29

manager   ~0052174

marking resolved for next version. Will need verification. I've added an error message when the email cannot be validated.