View Issue Details

IDProjectCategoryView StatusLast Update
0016811phpList 3 applicationInternationalization (l18n)public13-02-19 12:38
Reportersolmar 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPhplist 2.11OSLinuxOS VersionCentOS
Product Version2.11.7 
Target VersionFixed in Version2.11.11 
Summary0016811: System messages are not translated even if translation file is available
DescriptionSet Product version = 2.11.7 as the version that I use, 2.11.5, is not present in the menu.

Using Italian translation.

The automatic system messages, like "Phplist 2.11 Maillist Processing info" or "Message Sending has started", "Bounce processing info" are always sent out in English, even if the appropriate translation is present in the right file and directory. The admin of PHPlist is correctly translated so I assume the problem is not with the file, but with the application.

Maybe the problem lies in the fact that standard admin pages are generated by the browser, which calls other files and procedures, while system messages do not use it.
TagsNo tags attached.

Activities

michiel

11-06-13 12:23

manager   ~0052127

Yes, I noticed that as well, and it is particularly the case when you use commandline processing, because the language is then no longer picked up from the browser.

I've added

$default_system_language = 'en';

which can be set to "it" instead, so that this is used for the fallback language.

However, Italian does need quite a bit of work to be 100% translated :-) http://translate.phplist.com/it/