View Issue Details

IDProjectCategoryView StatusLast Update
0016799phplist applicationSubscriber Importpublic06-06-13 22:05
Reporterdymitar 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.10 
Target Version2.11.11Fixed in Version2.11.11 
Summary0016799: The parameter "Omit Invalid" is not working correctly during csv import.
DescriptionThe parameter is not working as expected.
The records are imported with invalid emails.
Steps To ReproduceImport file with invalid emails and all the records will be imported.
Additional InformationThe attached file fixes the problem, but I'm not sure if this is the correct fix.
See the changes from line 180 to 213
TagsNo tags attached.

Activities

dymitar

31-05-13 17:03

reporter  

import2.php (23,928 bytes)

dymitar

31-05-13 17:07

reporter   ~0052072

The attached file contains additional changes, related to my proposal in issue 0016798. These changes are not related to this issue. They are between line 92 and 108

michiel

06-06-13 22:05

manager   ~0052107

I've applied your Omit Invalid fix, Thanks!

I did not apply the email address verification to identify invalid. The reason is that this is kind of a "feature". It is possible that some in-house system does not have the correct email address, but there is still the need to add the person, be it, with an incorrect email address.

I know this may be outdated now, but it was "cutting edge" 10 years ago, when phpList was started, and it could not be expected that everyone had an email address :-)

I may review this decision. I'm open to good arguments.