View Issue Details

IDProjectCategoryView StatusLast Update
0016796phpList 3 applicationInterface - Administratorpublic03-06-13 20:09
Reportermichiel 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.9 
Target Version2.11.11Fixed in Version2.11.11 
Summary0016796: Review statistics exactness
DescriptionSplitting out the statistics issue from 0016788


Issue is, statistics include "not sent" entries, and are therefore incorrect


TagsNo tags attached.

Relationships

related to 0016788 new phpList 3 plugins Not able to send a message to subscribers who previously were excluded 
related to 0006499 resolvedmichiel phpList 3 application subtract bounces to calculate percentages 
has duplicate 0014253 resolvedmichiel phpList 3 application clicktracking totals: sent msgs is calculated wrong (especially for RSS msgs) 

Activities

michiel

29-05-13 16:39

manager   ~0052053


Hi Duncan
(made you developer, so I can assign things to you :-)

Can you specify the Statistics being wrong? The statistics overview page does an SQL Query that includes

um.status = "sent"

which afaict should ensure that "not sent" entries are excluded from the calculations.

duncanc

29-05-13 18:31

updater   ~0052054

The View Opens page, http://strontian/lists2.11.9/admin/?page=mviews, includes the 'not sent' rows from the usermessage table.
The sql has a count(status) to get the number of messages sent to the user.

The Find Subscribers page, http://strontian/lists2.11.9/admin/?page=users, includes 'not sent' in the total of messages sent to each user.
The sql has a count(*) to get the number of messages sent to the user.

There might be others, but I haven't looked closely as it seems to be a retrograde step to introduce the new value of 'not sent' for the status column. Up until now a row in usermessage means that the message was sent to the user.

michiel

29-05-13 21:43

manager   ~0052055

great, thanks, I'll look into it.

I think it's preferable to use the status column, as I intend to use the table for more stuff, eg, there is already the PREPARE_QUEUE, which marks them as "todo", so that the sending can be done by multiple processes.

michiel

31-05-13 14:47

manager   ~0052071

have added 'and status = "sent"' to all relevant queries